CVE-2026-53941 Uprobe gadgets: unprivileged container's ld.so.cache causes high CPU utilization and container startup DoS

Medium 6.9 Published Updated

An unprivileged container can cause high CPU usage and block other container startups by providing a crafted ld.so.cache file while an uprobe gadget is active.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-53941?

CVE-2026-53941 is a medium-severity denial of service vulnerability in inspektor-gadget, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Inspektor Gadget is a set of tools and framework for data collection and system inspection on Kubernetes clusters and Linux hosts using eBPF. From 0.27.0 until 0.53.1, the uprobe library resolver can allow an unprivileged container to consume excessive CPU and block other containers from starting by supplying a crafted /etc/ld.so.cache file while an uprobe-based gadget is active. The parser in pkg/uprobetracer/ldcache_parser.go trusts EntryCount enough to perform excessive iteration, computes cache1Len with overflowing uint32 arithmetic, and repeatedly calls readStringFromBytes in pkg/uprobetracer/bytes.go, where byte-by-byte immutable string concatenation produces quadratic work. While this processing occurs, pkg/container-hook holds the fanotify container-start pause, allowing a crafted cache to delay startup for roughly a minute, prevent Docker from starting other containers, and degrade monitoring. Processing caches from already-running containers can still consume CPU but does not hold the new-container startup pause, and the advisory establishes no confidentiality or integrity impact. This issue is fixed in version 0.53.1.

Weakness: CWE-770

Which versions are affected by CVE-2026-53941?

3 open source packages ship an affected version, including github.com/inspektor-gadget/inspektor-gadget.

PackageAffectedFixed in
github.com/inspektor-gadget/inspektor-gadget GoFrom 0.27.00.53.1
github.com/inspektor-gadget/inspektor-gadget GoFrom 0.27.00.53.1
github.com/inspektor-gadget/inspektor-gadget GoFrom 0.27.00.53.1

How do I fix CVE-2026-53941?

Upgrade github.com/inspektor-gadget/inspektor-gadget to 0.53.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-53941 being exploited?

There is no known exploitation of CVE-2026-53941 in the wild and no public exploit code.

Sources

Also known as GHSA-vjhx-2cqw-3q6q, GO-2026-6254.

Is CVE-2026-53941 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free