# CVE-2026-53943: Ghost: Cache-poisoning XSS in Ghost frontend via x-ghost-preview header

> Unauthenticated attackers can poison shared caches via the x-ghost-preview header to inject XSS, potentially taking over staff accounts if frontend and admin share a domain.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** BIT-ghost-2026-53943, GHSA-62q6-4hv4-vjrw

## What is CVE-2026-53943?

CVE-2026-53943 is a critical cross-site scripting vulnerability in TryGhost Ghost, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ghost is a Node.js content management system. From  until 6.37.0, when Ghost is behind a shared caching layer that results in cached content being shared between different visitors, an unauthenticated user could send an x-ghost-preview header that altered the rendered frontend response. In affected cache configurations, that response could be stored and served to subsequent visitors requesting the same page, allowing cache poisoning of request-specific preview output. When running Ghost's frontend and admin panel on the same domain this could be used to take over staff user accounts. When running these on different domains staff accounts have no exposure. This vulnerability is fixed in 6.37.0.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-53943?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 4.0.0 | 6.37.0 |
| `ghost` | npm | From 4.0.0 | 6.37.0 |
| `ghost` | npm | From 4.0.0 | 6.37.0 |

## How do I fix CVE-2026-53943?

Upgrade ghost to 6.37.0 or later.

## Is CVE-2026-53943 being exploited?

There is no known exploitation of CVE-2026-53943 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53943 and fix it if it is affected.

What it is: CVE-2026-53943 is a critical cross-site scripting vulnerability in TryGhost Ghost, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53943 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 4.0.0; fixed in 6.37.0
- ghost (npm): affected from 4.0.0; fixed in 6.37.0
- ghost (npm): affected from 4.0.0; fixed in 6.37.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53943/ (Markdown: https://insights.sbomify.com/CVE-2026-53943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53943
- OSV: https://osv.dev/vulnerability/CVE-2026-53943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53943/
Summaries are generated and may contain mistakes; the official description above is the record.
