CVE-2026-53944 Ghost: Private IP filtering bypass to make server-side requests to internal services
Medium 5.8
Published
Updated
Check this codebase for CVE-2026-53944 and fix it if it is affected.
What it is: CVE-2026-53944 is a medium-severity vulnerability in TryGhost Ghost, published on 24 Jun 2026.
Exploitation: There is no known exploitation of CVE-2026-53944 in the wild and no public exploit code.
Affected packages and fixed versions:
- ghost (Bitnami): affected from 6.0.9; fixed in 6.21.1
- ghost (npm): affected from 6.0.9; fixed in 6.21.1
- ghost (npm): affected from 6.0.9; fixed in 6.21.1
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2026-53944/ (Markdown: https://insights.sbomify.com/CVE-2026-53944/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-53944?
CVE-2026-53944 is a medium-severity vulnerability in TryGhost Ghost, published on 24 Jun 2026.
Official description
Ghost is a Node.js content management system. From 6.0.9 until 6.21.1, when making an external request, it is possible to bypass the IP filter that ensures the request isn't going to an internal service using an IPv6 literal which maps to a private IPv4 address. This vulnerability is fixed in 6.21.1.
Which versions are affected by CVE-2026-53944?
3 open source packages ship an affected version, including ghost.
| Package | Affected | Fixed in |
|---|---|---|
ghost Bitnami | From 6.0.9 | 6.21.1 |
ghost npm | From 6.0.9 | 6.21.1 |
ghost npm | From 6.0.9 | 6.21.1 |
How do I fix CVE-2026-53944?
Upgrade ghost to 6.21.1 or later.
Is CVE-2026-53944 being exploited?
There is no known exploitation of CVE-2026-53944 in the wild and no public exploit code.
Sources
Also known as BIT-ghost-2026-53944, GHSA-wvp2-4qqp-4h3r.