# CVE-2026-53954: Bugsink: DOS using large numbers of event tags

> Attackers with valid project DSNs can cause denial of service by submitting excessive event tags, delaying ingestion in Bugsink.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-5x67-j5xg-c5gj, PYSEC-2026-2403

## What is CVE-2026-53954?

CVE-2026-53954 is a medium-severity denial of service vulnerability in bugsink, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bugsink is a self-hosted error tracking tool. Prior to version 2.2.2, Bugsink stores every set of custom tags supplied with an incoming event, allowing a caller with a valid project DSN to submit an unusually large tag set and force excessive tag-row writes. Because Bugsink uses a single-writer database architecture, the expensive write transaction delays digestion of other events and causes a temporary ingestion denial of service. Version 2.2.2 applies the configurable MAX_EVENT_TAGS limit before storage. The impact is limited to availability for an instance accepting the event and does not expose stored data, modify existing events, or allow code execution. This issue is fixed in version 2.2.2.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-53954?

3 open source packages ship an affected version, including bugsink.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | All versions | 2.2.2 |
| `bugsink` | PyPI | All versions | 2.2.2 |
| `bugsink` | PyPI | All versions | 2.2.2 |

## How do I fix CVE-2026-53954?

Upgrade bugsink to 2.2.2 or later.

## Is CVE-2026-53954 being exploited?

There is no known exploitation of CVE-2026-53954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53954 and fix it if it is affected.

What it is: CVE-2026-53954 is a medium-severity denial of service vulnerability in bugsink, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53954 in the wild and no public exploit code.

Affected packages and fixed versions:
- bugsink (PyPI): affected all versions; fixed in 2.2.2
- bugsink (PyPI): affected all versions; fixed in 2.2.2
- bugsink (PyPI): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53954/ (Markdown: https://insights.sbomify.com/CVE-2026-53954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53954
- OSV: https://osv.dev/vulnerability/CVE-2026-53954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53954/
Summaries are generated and may contain mistakes; the official description above is the record.
