# CVE-2026-53957: Contentful MCP Server: export_space/import_space tools pass LLM-controlled `host`/`proxy` args to CMA client, redirecting server PAT to attacker-controlled endpoint

> Attackers can redirect API requests to malicious hosts via LLM-controlled arguments, stealing Contentful management tokens and gaining persistent access to spaces.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-2xhg-73j7-rrgx

## What is CVE-2026-53957?

CVE-2026-53957 is a high-severity server-side request forgery vulnerability in @contentful contentful-mcp-server, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contentful MCP Server is a Model Context Protocol server for the Contentful Management API. Prior to @contentful/mcp-server 1.7.19 and @contentful/mcp-tools 0.4.5, export_space and import_space in packages/mcp-tools/src/tools/jobs/space-to-space-migration/exportSpace.ts and packages/mcp-tools/src/tools/jobs/space-to-space-migration/importSpace.ts expose host, proxy, rawProxy, and insecure network options to LLM-controlled tool arguments and combine those options with the server's CONTENTFUL_MANAGEMENT_TOKEN. After space_to_space_migration_handler enables the migration tools, a direct MCP call or prompt injection through attacker-controlled Contentful content can redirect Contentful Management API requests and their Authorization header to an attacker-controlled host or proxy. The regular tools that use createToolClient are unaffected because those tools pin the host from server configuration. Exposure of the personal access token permits persistent out-of-band access to every Contentful space within the token's scope. This issue is fixed in @contentful/mcp-server 1.7.19 and @contentful/mcp-tools 0.4.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-53957?

4 open source packages ship an affected version, including @contentful/mcp-server and @contentful/mcp-tools.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@contentful/mcp-server` | npm | All versions | 1.7.19 |
| `@contentful/mcp-server` | npm | All versions | 1.7.19 |
| `@contentful/mcp-tools` | npm | All versions | 0.4.5 |
| `@contentful/mcp-tools` | npm | All versions | 0.4.5 |

## How do I fix CVE-2026-53957?

Upgrade @contentful/mcp-server to 1.7.19 or later.

## Is CVE-2026-53957 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53957 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53957 and fix it if it is affected.

What it is: CVE-2026-53957 is a high-severity server-side request forgery vulnerability in @contentful contentful-mcp-server, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53957 exists.

Affected packages and fixed versions:
- @contentful/mcp-server (npm): affected all versions; fixed in 1.7.19
- @contentful/mcp-server (npm): affected all versions; fixed in 1.7.19
- @contentful/mcp-tools (npm): affected all versions; fixed in 0.4.5
- @contentful/mcp-tools (npm): affected all versions; fixed in 0.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53957/ (Markdown: https://insights.sbomify.com/CVE-2026-53957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53957
- OSV: https://osv.dev/vulnerability/CVE-2026-53957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53957/
Summaries are generated and may contain mistakes; the official description above is the record.
