CVE-2026-53962 Discourse: Insufficient SVG sanitization logic

Medium 5.4 Published Updated

Insufficient SVG sanitization in Discourse allows attackers to execute cross-site scripting via crafted uploads or avatars.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-53962?

CVE-2026-53962 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, insufficient SVG sanitization in upload and user avatar handling could lead to cross-site scripting when a user visited specific URLs that are not normally part of community browsing. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.

Weakness: CWE-79

Which versions are affected by CVE-2026-53962?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.5, 2026.4.2, 2026.5.1

Products include Discourse Discourse.

How do I fix CVE-2026-53962?

Upgrade discourse to a fixed version for your release line: 2026.1.5, 2026.4.2 or 2026.5.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-53962 being exploited?

There is no known exploitation of CVE-2026-53962 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-53962, GHSA-jmcf-3367-78vv.

Is CVE-2026-53962 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free