{"answers":{"affected":"3 open source packages ship an affected version, including document-merge-service.","exploited":"There is no known exploitation of CVE-2026-53964 in the wild and no public exploit code.","fix":"Upgrade document-merge-service to 9.1.0 or later.","what":"CVE-2026-53964 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53964 and fix it if it is affected.\n\nWhat it is: CVE-2026-53964 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53964 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- document-merge-service (PyPI): affected all versions; fixed in 9.1.0\n- document-merge-service (PyPI): affected all versions; fixed in 9.1.0\n- document-merge-service (PyPI): affected all versions; fixed in 9.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53964/ (Markdown: https://insights.sbomify.com/CVE-2026-53964/index.md)","id":"CVE-2026-53964","markdown":"https://insights.sbomify.com/CVE-2026-53964/index.md","name":"CVE-2026-53964","record":{"aliases":["GHSA-w47q-945m-q9pc","PYSEC-2026-3830"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Document Merge Service","requires_auth":"high_privilege","summary":"Remote attackers can execute arbitrary code via server-side template injection in XLSX templates, compromising the server container.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Prior to version 9.1.0, a remote code execution (RCE) via server-side template injection (SSTI) allows for user supplied code to be executed in the server's context where it is executed as the document-merge-server user with the UID 901 thus giving an attacker considerable control over the container. The vulnerability is limited to XLSX templates, were the xltpl library uses a npn-sandboxed Jinja environment for the processing of the template. This issue has been patched in version 9.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Document Merge Service vulnerable to RCE via SSTI (xlsx tempaltes)","id":"CVE-2026-53964","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"MCP PHP SDK: Unbounded SSE buffer in HttpTransport enables client-side denial of service","id":"CVE-2026-53965"},"packages":[{"ecosystem":"PyPI","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"document-merge-service","purl":null,"source":"GHSA-w47q-945m-q9pc"},{"ecosystem":"PyPI","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"document-merge-service","purl":"pkg:pypi/document-merge-service","source":"GHSA-w47q-945m-q9pc"},{"ecosystem":"PyPI","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"document-merge-service","purl":"pkg:pypi/document-merge-service","source":"PYSEC-2026-3830"}],"prev":{"headline":"Discourse: Stored-XSS in 2FA delete confirmation modal","id":"CVE-2026-53963"},"products":["document-merge-service"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["adfinis"]},"summary":"Remote attackers can execute arbitrary code via server-side template injection in XLSX templates, compromising the server container.","url":"https://insights.sbomify.com/CVE-2026-53964/"}