# CVE-2026-53964: Document Merge Service vulnerable to RCE via SSTI (xlsx tempaltes)

> Remote attackers can execute arbitrary code via server-side template injection in XLSX templates, compromising the server container.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-w47q-945m-q9pc, PYSEC-2026-3830

## What is CVE-2026-53964?

CVE-2026-53964 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Prior to version 9.1.0, a remote code execution (RCE) via server-side template injection (SSTI) allows for user supplied code to be executed in the server's context where it is executed as the document-merge-server user with the UID 901 thus giving an attacker considerable control over the container. The vulnerability is limited to XLSX templates, were the xltpl library uses a npn-sandboxed Jinja environment for the processing of the template. This issue has been patched in version 9.1.0.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-53964?

3 open source packages ship an affected version, including document-merge-service.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `document-merge-service` | PyPI | All versions | 9.1.0 |
| `document-merge-service` | PyPI | All versions | 9.1.0 |
| `document-merge-service` | PyPI | All versions | 9.1.0 |

## How do I fix CVE-2026-53964?

Upgrade document-merge-service to 9.1.0 or later.

## Is CVE-2026-53964 being exploited?

There is no known exploitation of CVE-2026-53964 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53964 and fix it if it is affected.

What it is: CVE-2026-53964 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53964 in the wild and no public exploit code.

Affected packages and fixed versions:
- document-merge-service (PyPI): affected all versions; fixed in 9.1.0
- document-merge-service (PyPI): affected all versions; fixed in 9.1.0
- document-merge-service (PyPI): affected all versions; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53964/ (Markdown: https://insights.sbomify.com/CVE-2026-53964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53964
- OSV: https://osv.dev/vulnerability/CVE-2026-53964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53964/
Summaries are generated and may contain mistakes; the official description above is the record.
