CVE-2026-53965 MCP PHP SDK: Unbounded SSE buffer in HttpTransport enables client-side denial of service

Medium 6.9 Published Updated

A malicious server can exhaust client memory via unbounded SSE buffering in the MCP PHP SDK, causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-53965?

CVE-2026-53965 is a medium-severity denial of service vulnerability in modelcontextprotocol php-sdk, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The MCP PHP SDK (Composer package mcp/sdk) is the official Model Context Protocol SDK for PHP. In versions 0.5.0 through 0.7.0, the HTTP client transport reads a Server-Sent Events response stream incrementally and appends each chunk to an in-memory buffer with no upper bound. The buffer is only flushed when an SSE event delimiter, a double newline, is found, so a remote MCP server that streams response bytes without ever sending the delimiter causes the buffer to grow without limit. A malicious, compromised, or man-in-the-middle-controlled server that the client connects to over the HTTP transport can exploit this to exhaust the client process's memory, triggering a fatal allocation error or OS out-of-memory kill and denying service to the MCP client. The issue affects any client using HttpTransport against an untrusted server endpoint and does not require authentication or user interaction beyond initiating the connection. This issue is fixed in version 0.7.1.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2026-53965?

2 open source packages ship an affected version, including mcp/sdk.

PackageAffectedFixed in
mcp/sdk PackagistFrom 0.5.00.7.1
mcp/sdk PackagistFrom 0.5.00.7.1

How do I fix CVE-2026-53965?

Upgrade mcp/sdk to 0.7.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-53965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53965 exists.

Sources

Also known as GHSA-7m52-jw36-44r3.

Is CVE-2026-53965 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free