{"answers":{"affected":"4 open source packages ship an affected version, including getkirby/cms.","exploited":"There is no known exploitation of CVE-2026-54002 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.","what":"CVE-2026-54002 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54002 and fix it if it is affected.\n\nWhat it is: CVE-2026-54002 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-54002 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4\n- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4\n- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54002/ (Markdown: https://insights.sbomify.com/CVE-2026-54002/index.md)","id":"CVE-2026-54002","markdown":"https://insights.sbomify.com/CVE-2026-54002/index.md","name":"CVE-2026-54002","record":{"aliases":["GHSA-wr9h-4r83-f4v6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via unsanitized HTML/XML tags in Kirby CMS fields, leading to stored cross-site scripting.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-87","name":"Improper Neutralization of Alternate XSS Syntax"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites and plugins that use the writer or list fields or call Dom::sanitize(), Sane::sanitize(), Sane::Html::sanitize(), Sane::Svg::sanitize(), Sane::Xml::sanitize(), Sane::sanitizeFile(), or file sanitizeContents() with untrusted input allow malicious markup injected as children of an unknown HTML or XML tag to pass through Dom::sanitize() without being correctly sanitized, causing stored cross-site scripting. This issue is fixed in versions 4.9.4 and 5.4.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kirby: Cross-site scripting (XSS) from incomplete HTML/XML sanitization in `Dom::sanitize()`","id":"CVE-2026-54002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":7,"next":{"headline":"Kirby: External Initialization of the Panel on reverse proxy setups with the `Forwarded` header","id":"CVE-2026-54003"},"packages":[{"ecosystem":"Packagist","fixed":["4.9.4"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-wr9h-4r83-f4v6"},{"ecosystem":"Packagist","fixed":["4.9.4"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-wr9h-4r83-f4v6"},{"ecosystem":"Packagist","fixed":["5.4.4"],"introduced":["5.0.0-alpha.1"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-wr9h-4r83-f4v6"},{"ecosystem":"Packagist","fixed":["5.4.4"],"introduced":["5.0.0-alpha.1"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-wr9h-4r83-f4v6"}],"prev":{"headline":"osquery: Heap buffer overflow via `authenticode` table (Windows)","id":"CVE-2026-54001"},"products":["kirby"],"published":"2026-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["getkirby"]},"summary":"Attackers can inject malicious scripts via unsanitized HTML/XML tags in Kirby CMS fields, leading to stored cross-site scripting.","url":"https://insights.sbomify.com/CVE-2026-54002/"}