CVE-2026-54003 Kirby: External Initialization of the Panel on reverse proxy setups with the `Forwarded` header
Attackers can bypass local IP checks via spoofed headers to install the Panel and create an admin account on unconfigured Kirby sites behind reverse proxies.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54003?
CVE-2026-54003 is a critical authentication bypass vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is an open-source content management system. Prior to 4.9.4 and from 5.4.4, Kirby sites with no configured user accounts that run on publicly accessible servers behind a reverse proxy setting the Forwarded, X-Client-IP, or X-Real-IP request header could allow remote attackers to install the Panel and create the first admin user because local-IP checks trusted those headers incorrectly. This issue is fixed in versions 4.9.4 and 5.4.4.
Weakness: CWE-454
Which versions are affected by CVE-2026-54003?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
How do I fix CVE-2026-54003?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-54003 being exploited?
There is no known exploitation of CVE-2026-54003 in the wild and no public exploit code.
Sources
Also known as GHSA-whxw-24jc-cwmv.