# CVE-2026-54004: Kirby: Access to files of top-level drafts is not protected by permissions

> Unauthenticated attackers can access draft file contents via redirected URLs when file redirects are enabled, bypassing page access permissions.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-89cp-7p28-jffg

## What is CVE-2026-54004?

CVE-2026-54004 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites with content.fileRedirects enabled could redirect unauthenticated clean file URL requests for files stored in top-level draft pages to physical media URLs without checking page access permissions or preview tokens, leading to disclosure of draft file contents. This issue is fixed in versions 4.9.4 and 5.4.4.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-54004?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |

## How do I fix CVE-2026-54004?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.

## Is CVE-2026-54004 being exploited?

There is no known exploitation of CVE-2026-54004 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54004 and fix it if it is affected.

What it is: CVE-2026-54004 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54004 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54004/ (Markdown: https://insights.sbomify.com/CVE-2026-54004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54004
- OSV: https://osv.dev/vulnerability/CVE-2026-54004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54004/
Summaries are generated and may contain mistakes; the official description above is the record.
