CVE-2026-54005 Kirby: `pages.access` permission is not checked in the `site/find` REST API route
Authenticated users can bypass page access restrictions to read arbitrary published page content via the site/find API route.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54005?
CVE-2026-54005 is a high-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites where a role has the pages.access permission disabled allowed authenticated users who know or guess page IDs or UUIDs to retrieve page information, including full content and metadata, for arbitrary published pages through the /api/site/find route without authorization to access those pages. This issue is fixed in versions 4.9.4 and 5.4.4.
Weakness: CWE-862
Which versions are affected by CVE-2026-54005?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
How do I fix CVE-2026-54005?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-54005 being exploited?
There is no known exploitation of CVE-2026-54005 in the wild and no public exploit code.
Sources
Also known as GHSA-r3w8-2c5r-h9j9.