# CVE-2026-54005: Kirby: `pages.access` permission is not checked in the `site/find` REST API route

> Authenticated users can bypass page access restrictions to read arbitrary published page content via the site/find API route.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-r3w8-2c5r-h9j9

## What is CVE-2026-54005?

CVE-2026-54005 is a high-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites where a role has the pages.access permission disabled allowed authenticated users who know or guess page IDs or UUIDs to retrieve page information, including full content and metadata, for arbitrary published pages through the /api/site/find route without authorization to access those pages. This issue is fixed in versions 4.9.4 and 5.4.4.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-54005?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | All versions | 4.9.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |
| `getkirby/cms` | Packagist | From 5.0.0-alpha.1 | 5.4.4 |

## How do I fix CVE-2026-54005?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.

## Is CVE-2026-54005 being exploited?

There is no known exploitation of CVE-2026-54005 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54005 and fix it if it is affected.

What it is: CVE-2026-54005 is a high-severity missing authorization vulnerability in getkirby kirby, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54005 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4
- getkirby/cms (Packagist): affected from 5.0.0-alpha.1; fixed in 5.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54005/ (Markdown: https://insights.sbomify.com/CVE-2026-54005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54005
- OSV: https://osv.dev/vulnerability/CVE-2026-54005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54005/
Summaries are generated and may contain mistakes; the official description above is the record.
