# CVE-2026-54007: Open WebUI: Cross-origin postMessage confirmation bypass via action:submit

> An attacker can force an authenticated user to execute prompts and tools via cross-origin postMessage, leading to unauthorized actions and potential code execution.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-3vv5-8xxp-4f55, PYSEC-2026-2695

## What is CVE-2026-54007?

CVE-2026-54007 is a high-severity vulnerability in Openwebui Open Webui, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.6, the chat message listener allows non-same-origin input:prompt and action:submit messages, so an external site can set prompt text and trigger submitPrompt() in an authenticated victim session. I validated this with a cross-origin attacker page that auto-posted messages and caused unauthorized POST /api/v1/chats/new and POST /api/chat/completions requests containing attacker-controlled prompts. This enables cross-site forced actions and model/tool execution under victim privileges without consent. This vulnerability is fixed in 0.9.6.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-54007?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.6 |
| `open-webui` | PyPI | All versions | 0.9.6 |
| `open-webui` | PyPI | All versions | 0.9.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-54007?

Upgrade open-webui to 0.9.6 or later.

## Is CVE-2026-54007 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54007 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54007 and fix it if it is affected.

What it is: CVE-2026-54007 is a high-severity vulnerability in Openwebui Open Webui, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54007 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.6
- open-webui (PyPI): affected all versions; fixed in 0.9.6
- open-webui (PyPI): affected all versions; fixed in 0.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54007/ (Markdown: https://insights.sbomify.com/CVE-2026-54007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54007
- OSV: https://osv.dev/vulnerability/CVE-2026-54007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54007/
Summaries are generated and may contain mistakes; the official description above is the record.
