# CVE-2026-54017: Open WebUI: Path traversal / SSRF in terminal server proxy via encoded path traversal

> Authenticated users can exploit path traversal in the terminal server proxy to access unauthorized files and internal services via SSRF.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-r2wg-2mcr-66rv, PYSEC-2026-2751

## What is CVE-2026-54017?

CVE-2026-54017 is a high-severity path traversal vulnerability in Openwebui Open Webui, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.6, the terminal-server reverse proxy in `backend/open_webui/routers/terminals.py` does not fully confine the user-controlled `path` segment before forwarding it to an admin-configured terminal server. An authenticated user who has been granted access to a terminal server can craft `path` values containing encoded `../` traversal sequences that escape the intended path (or policy) scope on that server, reaching unintended endpoints and files on the terminal-server host. Where the terminal server fans requests out to internal services, this also gives SSRF-style reach into those services. This is a separate code path from the `/api/v1/retrieval/process/web` SSRF (GHSA-c6xv-rcvw-v685), with its own input. Two distinct vectors are consolidated here: first, raw path forwarding / single-encoded traversal (original report); and second, a bypass of the subsequently-added `_sanitize_proxy_path` mitigation using double-encoded dots (`%252e%252e`). The attacker-controlled input is the request `path`, supplied by the non-admin user, not anything an administrator configures, so this is not an admin-trust / Rule-9 situation. Version 0.9.6 fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54017?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.6 |
| `open-webui` | PyPI | All versions | 0.9.6 |
| `open-webui` | PyPI | All versions | 0.9.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-54017?

Upgrade open-webui to 0.9.6 or later.

## Is CVE-2026-54017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54017 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54017 and fix it if it is affected.

What it is: CVE-2026-54017 is a high-severity path traversal vulnerability in Openwebui Open Webui, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54017 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.6
- open-webui (PyPI): affected all versions; fixed in 0.9.6
- open-webui (PyPI): affected all versions; fixed in 0.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54017/ (Markdown: https://insights.sbomify.com/CVE-2026-54017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54017
- OSV: https://osv.dev/vulnerability/CVE-2026-54017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54017/
Summaries are generated and may contain mistakes; the official description above is the record.
