# CVE-2026-54021: Open WebUI: Authenticated users can target arbitrary configured Ollama backends via unguarded url_idx path parameter

> Authenticated users can bypass backend restrictions to access unauthorized Ollama servers by manipulating the url_idx parameter.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-9rpj-v7hf-vv2w, PYSEC-2026-2718

## What is CVE-2026-54021?

CVE-2026-54021 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.6, several direct, index-addressed Ollama proxy routes accept a caller-supplied url_idx path parameter and use it as a raw index into the admin-configured OLLAMA_BASE_URLS list. Access control on these routes validates only whether the user may use the requested model, never which backend the request is routed to. Any authenticated user can append an arbitrary url_idx to force their request onto an Ollama backend they were never authorized to reach, including internal, higher-privilege, or explicitly admin-disabled backends. This vulnerability is fixed in 0.9.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-54021?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.6 |
| `open-webui` | PyPI | All versions | 0.9.6 |
| `open-webui` | PyPI | All versions | 0.9.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-54021?

Upgrade open-webui to 0.9.6 or later.

## Is CVE-2026-54021 being exploited?

There is no known exploitation of CVE-2026-54021 in the wild and no public exploit code.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54021 and fix it if it is affected.

What it is: CVE-2026-54021 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54021 in the wild and no public exploit code.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.6
- open-webui (PyPI): affected all versions; fixed in 0.9.6
- open-webui (PyPI): affected all versions; fixed in 0.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54021/ (Markdown: https://insights.sbomify.com/CVE-2026-54021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54021
- OSV: https://osv.dev/vulnerability/CVE-2026-54021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54021/
Summaries are generated and may contain mistakes; the official description above is the record.
