# CVE-2026-54022: Open WebUI: Any authenticated user can read other users' private notes via Socket.IO

> Authenticated attackers can bypass authorization checks to read other users' private notes by manipulating document ID formats in Socket.IO requests.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-8788-j68r-3cgh, PYSEC-2026-2712

## What is CVE-2026-54022?

CVE-2026-54022 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.8.11, the ydoc:document:join Socket.IO handler checks note ownership only when the document_id starts with note: (colon). However, the YdocManager storage layer normalizes all document IDs by replacing colons with underscores (document_id.replace(":", "_")). An attacker can join a document room using note_<id> (underscore) instead of note:<id> (colon), bypassing the authorization check entirely while accessing the same underlying Yjs document. The server then returns the full document state, leaking the victim's private note contents. This vulnerability is fixed in 0.8.11.

Weakness: CWE-863 (Incorrect Authorization), CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2026-54022?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.8.11 |
| `open-webui` | PyPI | All versions | 0.8.11 |
| `open-webui` | PyPI | All versions | 0.8.11 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-54022?

Upgrade open-webui to 0.8.11 or later.

## Is CVE-2026-54022 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54022 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54022 and fix it if it is affected.

What it is: CVE-2026-54022 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54022 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.8.11
- open-webui (PyPI): affected all versions; fixed in 0.8.11
- open-webui (PyPI): affected all versions; fixed in 0.8.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54022/ (Markdown: https://insights.sbomify.com/CVE-2026-54022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54022
- OSV: https://osv.dev/vulnerability/CVE-2026-54022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54022/
Summaries are generated and may contain mistakes; the official description above is the record.
