# CVE-2026-54025: LibreChat: Stored XSS via unescaped image alt text in markdown artifact preview

> Attackers can inject malicious scripts via unescaped image alt text in markdown previews, executing code in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-3phr-62qf-cxf3

## What is CVE-2026-54025?

CVE-2026-54025 is a medium-severity cross-site scripting vulnerability in Librechat Librechat, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LibreChat is an enhanced ChatGPT clone that supports multiple AI providers. Prior to 0.8.4-rc1, there is a vulnerability in LibreChat's markdown artifact preview pipeline. The marked library v15.0.12 does not HTML-escape double-quote characters in image alt text when a custom renderer falls through to the default renderer. LibreChat's generateMarkdownHtml function (in client/src/utils/markdown.ts) installs a custom image renderer that returns false for URLs passing the isSafeUrl allowlist check, which causes marked to fall back to its built-in renderer. That built-in renderer inserts the raw alt text into the alt="..." attribute without escaping double-quote characters. An attacker can craft an alt text such as " onload="payload to break out of the attribute and inject an arbitrary event handler. The resulting HTML is then assigned to document.getElementById('content').innerHTML inside the Sandpack preview iframe, causing the payload to execute in the victim's browser. This vulnerability is fixed in 0.8.4-rc1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54025?

It affects 1 product.


Products: Librechat Librechat.

## How do I fix CVE-2026-54025?

No fix has been published for CVE-2026-54025 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54025 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54025 exists.

## Other vulnerabilities in Librechat Librechat

- [CVE-2026-32625](https://insights.sbomify.com/CVE-2026-32625/): LibreChat Exfiltrates Server Secrets via MCP Server URL Injection (critical 9.6)
- [CVE-2024-11167](https://insights.sbomify.com/CVE-2024-11167/): Improper Access Control in danny-avila/librechat (critical 9.4)
- [CVE-2026-22252](https://insights.sbomify.com/CVE-2026-22252/): LibreChat MCP Stdio Remote Command Execution (critical 9.1)
- [CVE-2025-69222](https://insights.sbomify.com/CVE-2025-69222/): LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions (critical 9.1)
- [CVE-2024-41704](https://insights.sbomify.com/CVE-2024-41704/): Path traversal in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54025 and fix it if it is affected.

What it is: CVE-2026-54025 is a medium-severity cross-site scripting vulnerability in Librechat Librechat, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54025 exists.

Affected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54025/ (Markdown: https://insights.sbomify.com/CVE-2026-54025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54025
- OSV: https://osv.dev/vulnerability/CVE-2026-54025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54025/
Summaries are generated and may contain mistakes; the official description above is the record.
