# CVE-2026-54030: LibreChat: Missing Resource Parameter Validation in MCP OAuth Flow

> Attackers can steal access tokens by exploiting missing validation in the MCP OAuth flow, potentially compromising user accounts and data.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-gvpj-vm2f-2m23

## What is CVE-2026-54030?

CVE-2026-54030 is a high-severity vulnerability in Librechat Librechat, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LibreChat is an enhanced ChatGPT clone that supports multiple AI providers. Prior to 0.8.5, LibreChat's MCP OAuth implementation does not validate that the resource parameter from OAuth Protected Resource metadata (RFC 9728) matches the configured MCP server URL, allowing a malicious MCP server to steal access tokens intended for a legitimate server. This vulnerability is fixed in 0.8.5.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-54030?

It affects 1 product.


Products: Librechat Librechat.

## How do I fix CVE-2026-54030?

No fix has been published for CVE-2026-54030 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54030 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54030 exists.

## Other vulnerabilities in Librechat Librechat

- [CVE-2026-32625](https://insights.sbomify.com/CVE-2026-32625/): LibreChat Exfiltrates Server Secrets via MCP Server URL Injection (critical 9.6)
- [CVE-2024-11167](https://insights.sbomify.com/CVE-2024-11167/): Improper Access Control in danny-avila/librechat (critical 9.4)
- [CVE-2026-22252](https://insights.sbomify.com/CVE-2026-22252/): LibreChat MCP Stdio Remote Command Execution (critical 9.1)
- [CVE-2025-69222](https://insights.sbomify.com/CVE-2025-69222/): LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions (critical 9.1)
- [CVE-2024-41704](https://insights.sbomify.com/CVE-2024-41704/): Path traversal in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54030 and fix it if it is affected.

What it is: CVE-2026-54030 is a high-severity vulnerability in Librechat Librechat, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54030 exists.

Affected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54030/ (Markdown: https://insights.sbomify.com/CVE-2026-54030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54030
- OSV: https://osv.dev/vulnerability/CVE-2026-54030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54030/
Summaries are generated and may contain mistakes; the official description above is the record.
