# CVE-2026-54037: LibreChat: Incomplete Fix for CVE-2025-7105 — /api/convos/duplicate Lacks Rate Limiting Applied to /api/convos/fork

> Authenticated users can exhaust server resources by bypassing rate limits on the conversation duplication endpoint, causing denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-g445-9wq6-jf3v

## What is CVE-2026-54037?

CVE-2026-54037 is a medium-severity denial of service vulnerability in Librechat Librechat, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreChat is an enhanced ChatGPT clone that supports multiple AI providers. Prior to 0.8.4-rc1, the fix for CVE-2025-7105 added forkIpLimiter and forkUserLimiter rate limiters to POST /api/convos/fork to prevent rapid-fire conversation duplication. However, the POST /api/convos/duplicate endpoint — which is in the same file and performs the exact same expensive database operations — was not given any rate limiter. An authenticated user can bypass the CVE-2025-7105 fix by using /duplicate instead of /fork to exhaust server resources. This vulnerability is fixed in 0.8.4-rc1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54037?

It affects 1 product.


Products: Librechat Librechat.

## How do I fix CVE-2026-54037?

No fix has been published for CVE-2026-54037 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54037 being exploited?

There is no known exploitation of CVE-2026-54037 in the wild and no public exploit code.

## Other vulnerabilities in Librechat Librechat

- [CVE-2026-32625](https://insights.sbomify.com/CVE-2026-32625/): LibreChat Exfiltrates Server Secrets via MCP Server URL Injection (critical 9.6)
- [CVE-2024-11167](https://insights.sbomify.com/CVE-2024-11167/): Improper Access Control in danny-avila/librechat (critical 9.4)
- [CVE-2026-22252](https://insights.sbomify.com/CVE-2026-22252/): LibreChat MCP Stdio Remote Command Execution (critical 9.1)
- [CVE-2025-69222](https://insights.sbomify.com/CVE-2025-69222/): LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions (critical 9.1)
- [CVE-2024-41704](https://insights.sbomify.com/CVE-2024-41704/): Path traversal in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54037 and fix it if it is affected.

What it is: CVE-2026-54037 is a medium-severity denial of service vulnerability in Librechat Librechat, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54037 in the wild and no public exploit code.

Affected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54037/ (Markdown: https://insights.sbomify.com/CVE-2026-54037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54037
- OSV: https://osv.dev/vulnerability/CVE-2026-54037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54037/
Summaries are generated and may contain mistakes; the official description above is the record.
