{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-54047 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-54047 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-54047 is a critical authentication bypass vulnerability in LaciSynchroni server, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54047 and fix it if it is affected.\n\nWhat it is: CVE-2026-54047 is a critical authentication bypass vulnerability in LaciSynchroni server, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54047 in the wild and no public exploit code.\n\nAffected product: LaciSynchroni server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54047/ (Markdown: https://insights.sbomify.com/CVE-2026-54047/index.md)","id":"CVE-2026-54047","markdown":"https://insights.sbomify.com/CVE-2026-54047/index.md","name":"CVE-2026-54047","record":{"aliases":["GHSA-gq4p-pxvg-6x9j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Dalamud sync server","requires_auth":"none","summary":"Attackers can impersonate any user by manipulating local config files due to missing server-side validation of OAuth2 identities against requested UIDs.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-602","name":"Client-Side Enforcement of Server-Side Security"},{"id":"CWE-349","name":"Acceptance of Extraneous Untrusted Data With Trusted Data"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"Laci Synchroni is a decentralized mod and appearance sync server and plugin for Dalamud. Versions of the backend prior to 1.2.3 have an improper authentication vulnerability in the application's OAuth2 login flow. The application relies on client-side state by trusting the `UID` field inside the `Authentications` object of a user's local `config.json` file. By manually editing this local file on their PC prior to logging in, a user can supply an arbitrary UID. Because the server fails to validate that the authenticated OAuth2 identity matches the requested UID, an attacker can fully impersonate any target user and perform actions on their behalf. This issue has been resolved in version 1.2.3. The patch modifies `AuthorizeOauthAsync` inside the `SecretKeyAuthenticatorService` to strictly bind the lookup of the requested User ID (`requestedUid`) to the record of the successfully authenticated identity (`primaryUid`). The server will no longer load or return session tokens for a requested UID unless it matches the verified, authenticated database record. No known workarounds are available.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Laci Synchroni Backend Vulnerable to Account Takeover / User Impersonation via Client-Side Configuration Manipulation","id":"CVE-2026-54047","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Apache Impala: Avro Schema URL Server-Side Request Forgery","id":"CVE-2026-54048"},"packages":[],"prev":{"headline":"LibreChat: 2FA Backup Code Regeneration Without OTP Verification Allows 2FA Bypass","id":"CVE-2026-54040"},"products":["server"],"published":"2026-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-11","vendors":["LaciSynchroni"]},"summary":"Attackers can impersonate any user by manipulating local config files due to missing server-side validation of OAuth2 identities against requested UIDs.","url":"https://insights.sbomify.com/CVE-2026-54047/"}