# CVE-2026-54047: Laci Synchroni Backend Vulnerable to Account Takeover / User Impersonation via Client-Side Configuration Manipulation

> Attackers can impersonate any user by manipulating local config files due to missing server-side validation of OAuth2 identities against requested UIDs.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Sep 2026
- **Updated:** 11 Sep 2026
- **Also known as:** GHSA-gq4p-pxvg-6x9j

## What is CVE-2026-54047?

CVE-2026-54047 is a critical authentication bypass vulnerability in LaciSynchroni server, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Laci Synchroni is a decentralized mod and appearance sync server and plugin for Dalamud. Versions of the backend prior to 1.2.3 have an improper authentication vulnerability in the application's OAuth2 login flow. The application relies on client-side state by trusting the `UID` field inside the `Authentications` object of a user's local `config.json` file. By manually editing this local file on their PC prior to logging in, a user can supply an arbitrary UID. Because the server fails to validate that the authenticated OAuth2 identity matches the requested UID, an attacker can fully impersonate any target user and perform actions on their behalf. This issue has been resolved in version 1.2.3. The patch modifies `AuthorizeOauthAsync` inside the `SecretKeyAuthenticatorService` to strictly bind the lookup of the requested User ID (`requestedUid`) to the record of the successfully authenticated identity (`primaryUid`). The server will no longer load or return session tokens for a requested UID unless it matches the verified, authenticated database record. No known workarounds are available.

Weakness: CWE-602 (Client-Side Enforcement of Server-Side Security), CWE-349 (Acceptance of Extraneous Untrusted Data With Trusted Data), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-54047?


## How do I fix CVE-2026-54047?

No fix has been published for CVE-2026-54047 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54047 being exploited?

There is no known exploitation of CVE-2026-54047 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54047 and fix it if it is affected.

What it is: CVE-2026-54047 is a critical authentication bypass vulnerability in LaciSynchroni server, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54047 in the wild and no public exploit code.

Affected product: LaciSynchroni server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54047/ (Markdown: https://insights.sbomify.com/CVE-2026-54047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54047
- OSV: https://osv.dev/vulnerability/CVE-2026-54047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54047/
Summaries are generated and may contain mistakes; the official description above is the record.
