CVE-2026-54049 Sakai Conversations has a Stored XSS Issue
Authenticated users can inject malicious scripts into Sakai Conversations posts, executing code in other users' browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-54049?
CVE-2026-54049 is a high-severity cross-site scripting vulnerability in sakaiproject sakai, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Sakai is a Collaboration and Learning Environment (CLE). From versions 23.0 to before 23.5, and versions 25.0 to before 25.3, the Sakai Conversations tool stores topic and post messages without HTML sanitization, and the frontend renders them using LitElement's unsafeHTML() directive, resulting in stored cross-site scripting (XSS). Any authenticated user with access to a site that has the Conversations tool enabled can inject arbitrary HTML and JavaScript that executes in the browsers of all other users who view that topic or post. This issue has been patched in versions 23.5, 25.3, and 26.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-54049?
6 open source packages ship an affected version, including org.sakaiproject.conversations:sakai-conversations-impl, org.sakaiproject.kernel:sakai-kernel-impl and org.sakaiproject.rubrics:rubrics-impl.
| Package | Affected | Fixed in |
|---|---|---|
org.sakaiproject.conversations:sakai-conversations-impl Maven | From 23.0 to 23.3 | None |
org.sakaiproject.conversations:sakai-conversations-impl Maven | From 23.0 to 23.3 | None |
org.sakaiproject.kernel:sakai-kernel-impl Maven | From 23.0 to 23.3 | None |
org.sakaiproject.kernel:sakai-kernel-impl Maven | From 23.0 to 23.3 | None |
org.sakaiproject.rubrics:rubrics-impl Maven | From 23.0 to 23.3 | None |
org.sakaiproject.rubrics:rubrics-impl Maven | From 23.0 to 23.3 | None |
How do I fix CVE-2026-54049?
No fix has been published for CVE-2026-54049 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-54049 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54049 exists.
Sources
Also known as GHSA-w2x5-gv52-9ccv.