# CVE-2026-54049: Sakai Conversations has a Stored XSS Issue

> Authenticated users can inject malicious scripts into Sakai Conversations posts, executing code in other users' browsers.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-w2x5-gv52-9ccv

## What is CVE-2026-54049?

CVE-2026-54049 is a high-severity cross-site scripting vulnerability in sakaiproject sakai, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Sakai is a Collaboration and Learning Environment (CLE). From versions 23.0 to before 23.5, and versions 25.0 to before 25.3, the Sakai Conversations tool stores topic and post messages without HTML sanitization, and the frontend renders them using LitElement's unsafeHTML() directive, resulting in stored cross-site scripting (XSS). Any authenticated user with access to a site that has the Conversations tool enabled can inject arbitrary HTML and JavaScript that executes in the browsers of all other users who view that topic or post. This issue has been patched in versions 23.5, 25.3, and 26.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54049?

6 open source packages ship an affected version, including org.sakaiproject.conversations:sakai-conversations-impl, org.sakaiproject.kernel:sakai-kernel-impl and org.sakaiproject.rubrics:rubrics-impl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.sakaiproject.conversations:sakai-conversations-impl` | Maven | From 23.0 to 23.3 | None |
| `org.sakaiproject.conversations:sakai-conversations-impl` | Maven | From 23.0 to 23.3 | None |
| `org.sakaiproject.kernel:sakai-kernel-impl` | Maven | From 23.0 to 23.3 | None |
| `org.sakaiproject.kernel:sakai-kernel-impl` | Maven | From 23.0 to 23.3 | None |
| `org.sakaiproject.rubrics:rubrics-impl` | Maven | From 23.0 to 23.3 | None |
| `org.sakaiproject.rubrics:rubrics-impl` | Maven | From 23.0 to 23.3 | None |

## How do I fix CVE-2026-54049?

No fix has been published for CVE-2026-54049 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54049 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54049 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54049 and fix it if it is affected.

What it is: CVE-2026-54049 is a high-severity cross-site scripting vulnerability in sakaiproject sakai, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54049 exists.

Affected packages and fixed versions:
- org.sakaiproject.conversations:sakai-conversations-impl (Maven): affected from 23.0 up to 23.3; no fix listed
- org.sakaiproject.conversations:sakai-conversations-impl (Maven): affected from 23.0 up to 23.3; no fix listed
- org.sakaiproject.kernel:sakai-kernel-impl (Maven): affected from 23.0 up to 23.3; no fix listed
- org.sakaiproject.kernel:sakai-kernel-impl (Maven): affected from 23.0 up to 23.3; no fix listed
- org.sakaiproject.rubrics:rubrics-impl (Maven): affected from 23.0 up to 23.3; no fix listed
- org.sakaiproject.rubrics:rubrics-impl (Maven): affected from 23.0 up to 23.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54049/ (Markdown: https://insights.sbomify.com/CVE-2026-54049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54049
- OSV: https://osv.dev/vulnerability/CVE-2026-54049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54049/
Summaries are generated and may contain mistakes; the official description above is the record.
