# CVE-2026-54051: Network-AI has an an OS Command Injection issue

> A compromised agent can execute arbitrary OS commands by bypassing the shell command allowlist via shell metacharacters in Network-AI.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-qw6v-5fcf-5666

## What is CVE-2026-54051?

CVE-2026-54051 is a critical command injection vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Network-AI is a TypeScript/Node.js multi-agent orchestrator. Prior to version 5.9.1, the agent sandbox gates shell commands behind an allowlist (`SandboxPolicy.isCommandAllowed`), which THREAT_MODEL.md calls the main control against a compromised agent (Adversary 3.2). The allowlist glob-matches the whole command string, but `ShellExecutor` runs that string through `/bin/sh -c`. So any wildcard allow such as `git *`, `npm *` or `node *` also matches `git status; <anything>`, and a scoped command becomes arbitrary execution. The issue is fixed in v5.9.1. `ShellExecutor` now executes via `spawn(file, args, { shell: false })` using a quote-aware parsed argv, so no shell is invoked. `SandboxPolicy.isCommandAllowed` and the new `SandboxPolicy.tokenizeCommand` reject any unquoted shell metacharacter (`; & | $ ` ` ` ( ) < > { }` newline) or unterminated quote before the allowlist glob match; quoted metacharacters are preserved as literal argument data. Users should upgrade to `network-ai@5.9.1` or later. As defense in depth, avoid broad wildcard allowlist entries such as `node *` / `npm *` which are direct code execution by design.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-54051?

2 open source packages ship an affected version, including network-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `network-ai` | npm | All versions | 5.9.1 |
| `network-ai` | npm | All versions | 5.9.1 |

## How do I fix CVE-2026-54051?

Upgrade network-ai to 5.9.1 or later.

## Is CVE-2026-54051 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54051 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54051 and fix it if it is affected.

What it is: CVE-2026-54051 is a critical command injection vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54051 exists.

Affected packages and fixed versions:
- network-ai (npm): affected all versions; fixed in 5.9.1
- network-ai (npm): affected all versions; fixed in 5.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54051/ (Markdown: https://insights.sbomify.com/CVE-2026-54051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54051
- OSV: https://osv.dev/vulnerability/CVE-2026-54051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54051/
Summaries are generated and may contain mistakes; the official description above is the record.
