# CVE-2026-54058: Pillow: Out-of-bounds read via attacker-controlled row stride on Pillow's mmap path (McIdas AREA files)

> An attacker can disclose adjacent process memory or cause a crash by crafting a malicious McIdas AREA image file processed by the Pillow library.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** BIT-pillow-2026-54058, DEBIAN-CVE-2026-54058, ECHO-f65c-df45-7f47, GHSA-62p4-gmf7-7g93, MINI-27fx-j72j-9hxv, MINI-3qrc-hh2c-6324, MINI-7pq8-7p6v-68m3, MINI-8qc5-7mpg-384w, MINI-96j2-jwj9-mmh5, MINI-h82v-82w7-qr3p, MINI-j3gh-fxq4-2grr, MINI-qw4m-hpqf-r47r, MINI-r46c-3hmq-fm9v, MINI-vrg7-ppj3-hh64, MINI-xc8g-fxjj-5gff, PYSEC-2026-3493, ROOT-APP-PYPI-CVE-2026-54058, UBUNTU-CVE-2026-54058, openSUSE-SU-2026:11839-1

## What is CVE-2026-54058?

CVE-2026-54058 is a high-severity vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. Prior to 12.3.0, when Pillow loads an uncompressed McIdas AREA image from a filename through the mmap raw codec path, attacker-controlled header words can set a row stride smaller than the natural row width, causing pixel access such as Image.tobytes(), getpixel, convert, or save to read beyond the mapped region and disclose adjacent process memory or fault. This issue is fixed in version 12.3.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-54058?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `python-graphifyy` | openSUSE:Tumbleweed | All versions | 0.9.65-1.1 |

Products: Python Pillow.

## How do I fix CVE-2026-54058?

Upgrade pillow to 12.3.0 or later.

## Is CVE-2026-54058 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54058 exists.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54058 and fix it if it is affected.

What it is: CVE-2026-54058 is a high-severity vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54058 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54058/ (Markdown: https://insights.sbomify.com/CVE-2026-54058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54058
- OSV: https://osv.dev/vulnerability/CVE-2026-54058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54058/
Summaries are generated and may contain mistakes; the official description above is the record.
