# CVE-2026-54063: Excelize: Unbounded Row Index Allocation in Worksheet Parser (checkSheet OOM/Panic DoS)

> Attackers can cause denial of service via memory exhaustion or panic by providing crafted XLSX files to applications using the Excelize library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-h69g-9hx6-f3v4, GO-2026-5960

## What is CVE-2026-54063?

CVE-2026-54063 is a high-severity denial of service vulnerability in qax-os excelize, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Excelize is a Go language library for reading and writing Microsoft Excel spreadsheets. Prior to 2.11.0, the checkSheet() function in github.com/xuri/excelize/v2 uses an attacker-controlled <row r="N"> XML attribute value directly as the length argument to make([]xlsxRow, row) without validating it against the Excel row limit (TotalRows = 1,048,576). A specially crafted XLSX file can trigger two denial-of-service variants: (A) an out-of-memory process kill when r=2147483647 forces a ~16 GB allocation attempt, and (B) a runtime panic via out-of-bounds slice indexing when r=-1. Any service that opens attacker-supplied XLSX files and calls GetCellValue is affected. No authentication is required. This issue is fixed in version 2.11.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54063?

3 open source packages ship an affected version, including github.com/xuri/excelize/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/xuri/excelize/v2` | Go | All versions | 2.11.0 |
| `github.com/xuri/excelize/v2` | Go | All versions | 2.11.0 |
| `github.com/xuri/excelize/v2` | Go | All versions | 2.11.0 |

Products: Excelize Excelize.

## How do I fix CVE-2026-54063?

Upgrade github.com/xuri/excelize/v2 to 2.11.0 or later.

## Is CVE-2026-54063 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54063 exists.

## Other vulnerabilities in qax-os excelize

- [CVE-2026-107211](https://insights.sbomify.com/CVE-2026-107211/): Excelize: Unchecked pivot-cache field index in extractPivotTableFields causes unrecoverable panic (high 8.7)
- [CVE-2026-107213](https://insights.sbomify.com/CVE-2026-107213/): Excelize: Nil-pointer dereference in GetSlicers when a worksheet has extLst present but no drawing element (high 8.7)
- [CVE-2026-59161](https://insights.sbomify.com/CVE-2026-59161/): Excelize: Streaming GetRows row-bound bypass causes attacker-controlled allocation (high 8.7)
- [CVE-2026-107212](https://insights.sbomify.com/CVE-2026-107212/): Excelize: Unbounded row number in Rows.Columns makes GetRows and the Rows iterator loop for days (high 7.5)
- [CVE-2026-107214](https://insights.sbomify.com/CVE-2026-107214/): Excelize Decrypt: unrecoverable panics on malformed OLE/CFB encrypted workbooks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54063 and fix it if it is affected.

What it is: CVE-2026-54063 is a high-severity denial of service vulnerability in qax-os excelize, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54063 exists.

Affected packages and fixed versions:
- github.com/xuri/excelize/v2 (Go): affected all versions; fixed in 2.11.0
- github.com/xuri/excelize/v2 (Go): affected all versions; fixed in 2.11.0
- github.com/xuri/excelize/v2 (Go): affected all versions; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54063/ (Markdown: https://insights.sbomify.com/CVE-2026-54063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54063
- OSV: https://osv.dev/vulnerability/CVE-2026-54063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54063/
Summaries are generated and may contain mistakes; the official description above is the record.
