{"answers":{"affected":"2 open source packages ship an affected version, including com.arcadedb:arcadedb-engine.","exploited":"There is no known exploitation of CVE-2026-54077 in the wild and no public exploit code.","fix":"Upgrade com.arcadedb:arcadedb-engine to 26.6.1 or later.","what":"CVE-2026-54077 is a high-severity server-side request forgery vulnerability in ArcadeData arcadedb, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54077 and fix it if it is affected.\n\nWhat it is: CVE-2026-54077 is a high-severity server-side request forgery vulnerability in ArcadeData arcadedb, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54077 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.arcadedb:arcadedb-engine (Maven): affected all versions; fixed in 26.6.1\n- com.arcadedb:arcadedb-engine (Maven): affected all versions; fixed in 26.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54077/ (Markdown: https://insights.sbomify.com/CVE-2026-54077/index.md)","id":"CVE-2026-54077","markdown":"https://insights.sbomify.com/CVE-2026-54077/index.md","name":"CVE-2026-54077","record":{"aliases":["GHSA-8w86-m9h8-hvqg"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ArcadeDB database","requires_auth":"low_privilege","summary":"Authenticated users can exploit the IMPORT DATABASE command to perform Server-Side Request Forgery and read arbitrary local files via file:// paths.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"ArcadeDB is a Multi-Model DBMS. Prior to 26.6.1, the IMPORT DATABASE statement in engine/src/main/java/com/arcadedb/query/sql/parser/ImportDatabaseStatement.java did not require administrative privileges and passed its source to integration/src/main/java/com/arcadedb/integration/importer/SourceDiscovery.java without validation. An authenticated user with SQL command access through /api/v1/command or /api/v1/query can supply HTTP or HTTPS destinations to make server-side requests to internal services, or file:// paths to read files accessible to the server process and ingest the results as queryable records. The XML importer also permits DTD processing and external entities, enabling entity expansion. The root-only /api/v1/server administration endpoint is not affected. The fix requires updateSecurity permission, blocks local-network import destinations by default through arcadedb.server.security.importBlockLocalNetworks, supports the arcadedb.server.security.importAllowedLocalPaths file allow-list, and disables XML DTD processing and external entities. This issue is fixed in version 26.6.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ArcadeDB: IMPORT DATABASE allows SSRF and arbitrary local file read by authenticated users","id":"CVE-2026-54077","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"veraPDF Validation XXE via Rich Text","id":"CVE-2026-54078"},"packages":[{"ecosystem":"Maven","fixed":["26.6.1"],"introduced":["0"],"last_affected":[],"package":"com.arcadedb:arcadedb-engine","purl":null,"source":"GHSA-8w86-m9h8-hvqg"},{"ecosystem":"Maven","fixed":["26.6.1"],"introduced":["0"],"last_affected":[],"package":"com.arcadedb:arcadedb-engine","purl":"pkg:maven/com.arcadedb/arcadedb-engine","source":"GHSA-8w86-m9h8-hvqg"}],"prev":{"headline":"ArcadeDB: Read-only users can mutate database schema (incomplete fix of CVE-2026-44221)","id":"CVE-2026-54076"},"products":["arcadedb","arcadedb-engine"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["ArcadeData","com.arcadedb"]},"summary":"Authenticated users can exploit the IMPORT DATABASE command to perform Server-Side Request Forgery and read arbitrary local files via file:// paths.","url":"https://insights.sbomify.com/CVE-2026-54077/"}