{"answers":{"affected":"2 open source packages ship an affected version, including easycorp/easyadmin-bundle.","exploited":"There is no known exploitation of CVE-2026-54087 in the wild and no public exploit code.","fix":"Upgrade easycorp/easyadmin-bundle to 5.0.13 or later.","what":"CVE-2026-54087 is a high-severity cross-site scripting vulnerability in EasyCorp EasyAdminBundle, published on 14 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54087 and fix it if it is affected.\n\nWhat it is: CVE-2026-54087 is a high-severity cross-site scripting vulnerability in EasyCorp EasyAdminBundle, published on 14 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-54087 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- easycorp/easyadmin-bundle (Packagist): affected from 5.0.0; fixed in 5.0.13\n- easycorp/easyadmin-bundle (Packagist): affected from 5.0.0; fixed in 5.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54087/ (Markdown: https://insights.sbomify.com/CVE-2026-54087/index.md)","id":"CVE-2026-54087","markdown":"https://insights.sbomify.com/CVE-2026-54087/index.md","name":"CVE-2026-54087","record":{"aliases":["GHSA-8559-gwj3-q37r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony admin bundle","requires_auth":"low_privilege","summary":"Attackers can upload malicious files to trigger stored XSS in admin views, potentially stealing session tokens and escalating privileges.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"EasyAdmin is a fast and modern admin generator for Symfony applications. From 5.0.0 until 5.0.13, FileField and ImageField can accept browser-executable uploads while templates/crud/field/file.html.twig links to stored files for inline same-origin rendering without a download attribute or Content-Disposition attachment header. When uploads are stored under the public web root, an attacker with access to an affected form can upload HTML through FileField or SVG through ImageField, and JavaScript executes in an authenticated administrator's origin when the file is opened from the backend. Exploitation requires a privilege gap between the uploader and viewer. The issue can expose session or CSRF tokens and enable privilege escalation, but does not permit PHP or PHTML code execution because Symfony guessExtension does not produce those stored extensions. This issue is fixed in version 5.0.13.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"EasyAdmin: Stored Cross-Site Scripting (XSS) via uploaded files served inline in FileField and ImageField","id":"CVE-2026-54087","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"File Browser: Command Injection via Authentication Hook Shell Substitution (Pre-Authentication RCE)","id":"CVE-2026-54088"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.13"],"introduced":["5.0.0"],"last_affected":[],"package":"easycorp/easyadmin-bundle","purl":null,"source":"GHSA-8559-gwj3-q37r"},{"ecosystem":"Packagist","fixed":["5.0.13"],"introduced":["5.0.0"],"last_affected":[],"package":"easycorp/easyadmin-bundle","purl":"pkg:composer/easycorp/easyadmin-bundle","source":"GHSA-8559-gwj3-q37r"}],"prev":{"headline":"SLE API for Java: Uncontrolled Memory Allocation / handled exception leading to Denial of Service","id":"CVE-2026-54086"},"products":["EasyAdminBundle"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["EasyCorp"]},"summary":"Attackers can upload malicious files to trigger stored XSS in admin views, potentially stealing session tokens and escalating privileges.","url":"https://insights.sbomify.com/CVE-2026-54087/"}