# CVE-2026-54087: EasyAdmin: Stored Cross-Site Scripting (XSS) via uploaded files served inline in FileField and ImageField

> Attackers can upload malicious files to trigger stored XSS in admin views, potentially stealing session tokens and escalating privileges.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-8559-gwj3-q37r

## What is CVE-2026-54087?

CVE-2026-54087 is a high-severity cross-site scripting vulnerability in EasyCorp EasyAdminBundle, published on 14 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

EasyAdmin is a fast and modern admin generator for Symfony applications. From 5.0.0 until 5.0.13, FileField and ImageField can accept browser-executable uploads while templates/crud/field/file.html.twig links to stored files for inline same-origin rendering without a download attribute or Content-Disposition attachment header. When uploads are stored under the public web root, an attacker with access to an affected form can upload HTML through FileField or SVG through ImageField, and JavaScript executes in an authenticated administrator's origin when the file is opened from the backend. Exploitation requires a privilege gap between the uploader and viewer. The issue can expose session or CSRF tokens and enable privilege escalation, but does not permit PHP or PHTML code execution because Symfony guessExtension does not produce those stored extensions. This issue is fixed in version 5.0.13.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-54087?

2 open source packages ship an affected version, including easycorp/easyadmin-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `easycorp/easyadmin-bundle` | Packagist | From 5.0.0 | 5.0.13 |
| `easycorp/easyadmin-bundle` | Packagist | From 5.0.0 | 5.0.13 |

## How do I fix CVE-2026-54087?

Upgrade easycorp/easyadmin-bundle to 5.0.13 or later.

## Is CVE-2026-54087 being exploited?

There is no known exploitation of CVE-2026-54087 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54087 and fix it if it is affected.

What it is: CVE-2026-54087 is a high-severity cross-site scripting vulnerability in EasyCorp EasyAdminBundle, published on 14 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54087 in the wild and no public exploit code.

Affected packages and fixed versions:
- easycorp/easyadmin-bundle (Packagist): affected from 5.0.0; fixed in 5.0.13
- easycorp/easyadmin-bundle (Packagist): affected from 5.0.0; fixed in 5.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54087/ (Markdown: https://insights.sbomify.com/CVE-2026-54087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54087
- OSV: https://osv.dev/vulnerability/CVE-2026-54087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54087/
Summaries are generated and may contain mistakes; the official description above is the record.
