CVE-2026-5412 Juju CloudSpec API could leak senstive information

Critical 9.9 Published Updated

An authenticated low-privileged user can access sensitive cloud credentials via the CloudSpec API due to missing authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-5412?

CVE-2026-5412 is a critical missing authorization vulnerability in Canonical Juju, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Juju versions prior to 2.9.57 and 3.6.21, an authorization issue exists in the Controller facade. An authenticated user can call the CloudSpec API method to extract the cloud credentials used to bootstrap the controller. This allows a low-privileged user to access sensitive credentials. This issue is resolved in Juju versions 2.9.57 and 3.6.21.

Weakness: CWE-285

Which versions are affected by CVE-2026-5412?

3 open source packages ship an affected version, including github.com/juju/juju. It affects 1 product.

PackageAffectedFixed in
github.com/juju/juju GoAll versions0.0.0-20260408003526-d395054dc2c3
github.com/juju/juju GoAll versions0.0.0-20260408003526-d395054dc2c3
github.com/juju/juju GoAll versions0.0.0-20260408003526-d395054dc2c3

Products include Canonical Juju.

How do I fix CVE-2026-5412?

Upgrade github.com/juju/juju to 0.0.0-20260408003526-d395054dc2c3 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-5412 being exploited?

There is no known exploitation of CVE-2026-5412 in the wild and no public exploit code.

Sources

Also known as GHSA-w5fq-8965-c969, GO-2026-5692.

Is CVE-2026-5412 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free