# CVE-2026-54147: http4k: `DigestAuthProvider.verify` ignored configured algorithm and did not bind to request URI

> Digest authentication verification ignores configured algorithms, forcing weak MD5 usage and enabling collision-based attacks against deployments expecting stronger hashing.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-vxxm-wwqh-mh47

## What is CVE-2026-54147?

CVE-2026-54147 is a medium-severity vulnerability in http4k, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

http4k is a functional toolkit for Kotlin HTTP applications. Prior to 4.51.0.0, 5.42.0.0, and 6.50.0.0, DigestAuthProvider.verify in http4k-security-digest ignores its configured algorithm parameter and verifies every Digest response with hardcoded MD5. Deployments configured for SHA-256 therefore receive weaker MD5-based verification, exposing Digest authentication to collision-related attack paths that depend on the hash function's collision resistance. This issue is fixed in versions 4.51.0.0, 5.42.0.0, and 6.50.0.0.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2026-54147?

6 open source packages ship an affected version, including org.http4k:http4k-security-digest.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4k:http4k-security-digest` | Maven | All versions to 4.48.2.0 | None |
| `org.http4k:http4k-security-digest` | Maven | All versions to 4.48.2.0 | None |
| `org.http4k:http4k-security-digest` | Maven | From 5.0.0.0 | 5.42.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 5.0.0.0 | 5.42.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 6.0.0.0 | 6.50.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 6.0.0.0 | 6.50.0.0 |

## How do I fix CVE-2026-54147?

Upgrade org.http4k:http4k-security-digest to a fixed version for your release line: 5.42.0.0 or 6.50.0.0.

## Is CVE-2026-54147 being exploited?

There is no known exploitation of CVE-2026-54147 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54147 and fix it if it is affected.

What it is: CVE-2026-54147 is a medium-severity vulnerability in http4k, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54147 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4k:http4k-security-digest (Maven): affected all versions up to 4.48.2.0; no fix listed
- org.http4k:http4k-security-digest (Maven): affected all versions up to 4.48.2.0; no fix listed
- org.http4k:http4k-security-digest (Maven): affected from 5.0.0.0; fixed in 5.42.0.0
- org.http4k:http4k-security-digest (Maven): affected from 5.0.0.0; fixed in 5.42.0.0
- org.http4k:http4k-security-digest (Maven): affected from 6.0.0.0; fixed in 6.50.0.0
- org.http4k:http4k-security-digest (Maven): affected from 6.0.0.0; fixed in 6.50.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54147/ (Markdown: https://insights.sbomify.com/CVE-2026-54147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54147
- OSV: https://osv.dev/vulnerability/CVE-2026-54147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54147/
Summaries are generated and may contain mistakes; the official description above is the record.
