CVE-2026-54148 http4k: `DigestAuthProvider.verify` did not bind to request URI
Attackers can replay captured Digest authentication responses against different URLs to bypass security controls and gain unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-54148?
CVE-2026-54148 is a high-severity authentication bypass vulnerability in http4k, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
http4k is a functional toolkit for Kotlin HTTP applications. Prior to 4.51.0.0, 5.42.0.0, and 6.50.0.0, DigestAuthProvider.verify in http4k-security-digest does not compare the uri parameter in an Authorization: Digest response with the actual request URL. An attacker who captures a valid Digest authentication response can replay it against another URL served by the same realm, bypassing the per-request-URI binding and potentially gaining unauthorized read or write access. This issue is fixed in versions 4.51.0.0, 5.42.0.0, and 6.50.0.0.
Weakness: CWE-294
Which versions are affected by CVE-2026-54148?
6 open source packages ship an affected version, including org.http4k:http4k-security-digest.
| Package | Affected | Fixed in |
|---|---|---|
org.http4k:http4k-security-digest Maven | From 4.0.0.0 | 4.51.0.0 |
org.http4k:http4k-security-digest Maven | From 4.0.0.0 | 4.51.0.0 |
org.http4k:http4k-security-digest Maven | From 5.0.0.0 | 5.42.0.0 |
org.http4k:http4k-security-digest Maven | From 5.0.0.0 | 5.42.0.0 |
org.http4k:http4k-security-digest Maven | From 6.0.0.0 | 6.50.0.0 |
org.http4k:http4k-security-digest Maven | From 6.0.0.0 | 6.50.0.0 |
How do I fix CVE-2026-54148?
Upgrade org.http4k:http4k-security-digest to a fixed version for your release line: 4.51.0.0, 5.42.0.0 or 6.50.0.0.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-54148 being exploited?
There is no known exploitation of CVE-2026-54148 in the wild and no public exploit code.
Sources
Also known as GHSA-p28p-j94q-pg32.