# CVE-2026-54149: MaxKB MCP tool import validation bypass allows post-authentication remote code execution

> Authenticated users can achieve remote code execution by importing malicious MCP tool files with stdio transport in MaxKB.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-4pr3-9xhm-98x5

## What is CVE-2026-54149?

CVE-2026-54149 is a high-severity command injection vulnerability in 1Panel-dev MaxKB, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. Prior to 2.10.0-lts, MaxKB tool import functionality in apps/tools/serializers/tool.py and MCP referencing mode in apps/application/chat_pipeline/step/chat_step/impl/base_chat_step.py do not consistently validate MCP transport type, allowing an authenticated user to import a .tool file containing stdio transport with malicious commands and trigger the configuration through an AI Chat node so MultiServerMCPClient executes arbitrary system commands. This issue is fixed in version 2.10.0-lts.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-54149?


## How do I fix CVE-2026-54149?

No fix has been published for CVE-2026-54149 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54149 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54149 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54149 and fix it if it is affected.

What it is: CVE-2026-54149 is a high-severity command injection vulnerability in 1Panel-dev MaxKB, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54149 exists.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54149/ (Markdown: https://insights.sbomify.com/CVE-2026-54149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54149
- OSV: https://osv.dev/vulnerability/CVE-2026-54149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54149/
Summaries are generated and may contain mistakes; the official description above is the record.
