{"answers":{"affected":"2 open source packages ship an affected version, including node-opcua.","exploited":"There is no known exploitation of CVE-2026-54156 in the wild and no public exploit code.","fix":"Upgrade node-opcua to 2.166.0 or later.","what":"CVE-2026-54156 is a high-severity denial of service vulnerability in node-opcua, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54156 and fix it if it is affected.\n\nWhat it is: CVE-2026-54156 is a high-severity denial of service vulnerability in node-opcua, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54156 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-opcua (npm): affected all versions; fixed in 2.166.0\n- node-opcua (npm): affected all versions; fixed in 2.166.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54156/ (Markdown: https://insights.sbomify.com/CVE-2026-54156/index.md)","id":"CVE-2026-54156","markdown":"https://insights.sbomify.com/CVE-2026-54156/index.md","name":"CVE-2026-54156","record":{"aliases":["GHSA-6wvw-vrw4-363w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OPC UA library","requires_auth":"none","summary":"Unauthenticated attackers can exhaust server memory by creating unlimited sessions, causing a denial of service in node-opcua applications.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"node-opcua is an OPC UA implementation for TypeScript and Node.js. Prior to 2.166.0, the process-global g_alreadyUsedNonce cache used by nonceAlreadyBeenUsed in packages/node-opcua-secure-channel/source/server/server_secure_channel_layer.ts records nonces from OpenSecureChannelRequest and CreateSession without expiration or a size limit. An unauthenticated remote attacker can repeatedly create sessions with unique nonces, causing entries to persist after session expiry and accumulate across connection cycles even when maxSessions=10 limits concurrent sessions. The resulting unbounded heap growth can exhaust the default Node.js heap and crash the node-opcua server process. This issue is fixed in version 2.166.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"node-opcua: Unbounded nonce cache enables unauthenticated heap exhaustion DoS","id":"CVE-2026-54156","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"LobeHub: Unauthenticated SSRF in `/webapi/proxy`","id":"CVE-2026-54157"},"packages":[{"ecosystem":"npm","fixed":["2.166.0"],"introduced":["0"],"last_affected":[],"package":"node-opcua","purl":null,"source":"GHSA-6wvw-vrw4-363w"},{"ecosystem":"npm","fixed":["2.166.0"],"introduced":["0"],"last_affected":[],"package":"node-opcua","purl":"pkg:npm/node-opcua","source":"GHSA-6wvw-vrw4-363w"}],"prev":{"headline":"node-opcua: Missing nonce verification in UserNameIdentityToken authentication","id":"CVE-2026-54155"},"products":["node-opcua"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["node-opcua"]},"summary":"Unauthenticated attackers can exhaust server memory by creating unlimited sessions, causing a denial of service in node-opcua applications.","url":"https://insights.sbomify.com/CVE-2026-54156/"}