# CVE-2026-54156: node-opcua: Unbounded nonce cache enables unauthenticated heap exhaustion DoS

> Unauthenticated attackers can exhaust server memory by creating unlimited sessions, causing a denial of service in node-opcua applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-6wvw-vrw4-363w

## What is CVE-2026-54156?

CVE-2026-54156 is a high-severity denial of service vulnerability in node-opcua, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-opcua is an OPC UA implementation for TypeScript and Node.js. Prior to 2.166.0, the process-global g_alreadyUsedNonce cache used by nonceAlreadyBeenUsed in packages/node-opcua-secure-channel/source/server/server_secure_channel_layer.ts records nonces from OpenSecureChannelRequest and CreateSession without expiration or a size limit. An unauthenticated remote attacker can repeatedly create sessions with unique nonces, causing entries to persist after session expiry and accumulate across connection cycles even when maxSessions=10 limits concurrent sessions. The resulting unbounded heap growth can exhaust the default Node.js heap and crash the node-opcua server process. This issue is fixed in version 2.166.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54156?

2 open source packages ship an affected version, including node-opcua.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-opcua` | npm | All versions | 2.166.0 |
| `node-opcua` | npm | All versions | 2.166.0 |

## How do I fix CVE-2026-54156?

Upgrade node-opcua to 2.166.0 or later.

## Is CVE-2026-54156 being exploited?

There is no known exploitation of CVE-2026-54156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54156 and fix it if it is affected.

What it is: CVE-2026-54156 is a high-severity denial of service vulnerability in node-opcua, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54156 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-opcua (npm): affected all versions; fixed in 2.166.0
- node-opcua (npm): affected all versions; fixed in 2.166.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54156/ (Markdown: https://insights.sbomify.com/CVE-2026-54156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54156
- OSV: https://osv.dev/vulnerability/CVE-2026-54156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54156/
Summaries are generated and may contain mistakes; the official description above is the record.
