{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/lobehub.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54157 exists.","fix":"Upgrade @lobehub/lobehub to 2.1.57 or later.","what":"CVE-2026-54157 is a critical server-side request forgery vulnerability in lobehub, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54157 and fix it if it is affected.\n\nWhat it is: CVE-2026-54157 is a critical server-side request forgery vulnerability in lobehub, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54157 exists.\n\nAffected packages and fixed versions:\n- @lobehub/lobehub (npm): affected all versions; fixed in 2.1.57\n- @lobehub/lobehub (npm): affected all versions; fixed in 2.1.57\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54157/ (Markdown: https://insights.sbomify.com/CVE-2026-54157/index.md)","id":"CVE-2026-54157","markdown":"https://insights.sbomify.com/CVE-2026-54157/index.md","name":"CVE-2026-54157","record":{"aliases":["GHSA-xmwj-c75x-6346"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LobeHub web application","requires_auth":"high_privilege","summary":"Unauthenticated attackers can exploit an SSRF vulnerability in LobeHub to make arbitrary server-side requests and leak sensitive deployment details.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"LobeHub is a work-and-lifestyle space to find, build, and collaborate with agent teammates that grow with you. Prior to 2.1.57, the /webapi/proxy endpoint on app.lobehub.com accepts a URL in the POST body and fetches it server-side without any authentication. An attacker can use this to make arbitrary outbound requests from LobeHub's infrastructure, leak Vercel deployment details, and inject cookies on the lobehub.com domain through reflected Set-Cookie headers. This vulnerability is fixed in 2.1.57.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-54157.yaml","stars":null,"title":"LobeHub LobeChat \u003c= 2.1.56 - Server-Side Request Forgery"}],"tier":"weaponised"},"has_fix":true,"headline":"LobeHub: Unauthenticated SSRF in `/webapi/proxy`","id":"CVE-2026-54157","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"SiYuan: Stored XSS to RCE via attribute-view cell rendering in genAVValueHTML()","id":"CVE-2026-54158"},"packages":[{"ecosystem":"npm","fixed":["2.1.57"],"introduced":["0"],"last_affected":[],"package":"@lobehub/lobehub","purl":null,"source":"GHSA-xmwj-c75x-6346"},{"ecosystem":"npm","fixed":["2.1.57"],"introduced":["0"],"last_affected":[],"package":"@lobehub/lobehub","purl":"pkg:npm/%40lobehub/lobehub","source":"GHSA-xmwj-c75x-6346"}],"prev":{"headline":"node-opcua: Unbounded nonce cache enables unauthenticated heap exhaustion DoS","id":"CVE-2026-54156"},"products":["lobehub"],"published":"2026-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["lobehub"]},"summary":"Unauthenticated attackers can exploit an SSRF vulnerability in LobeHub to make arbitrary server-side requests and leak sensitive deployment details.","url":"https://insights.sbomify.com/CVE-2026-54157/"}