# CVE-2026-54157: LobeHub: Unauthenticated SSRF in `/webapi/proxy`

> Unauthenticated attackers can exploit an SSRF vulnerability in LobeHub to make arbitrary server-side requests and leak sensitive deployment details.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-xmwj-c75x-6346

## What is CVE-2026-54157?

CVE-2026-54157 is a critical server-side request forgery vulnerability in lobehub, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LobeHub is a work-and-lifestyle space to find, build, and collaborate with agent teammates that grow with you. Prior to 2.1.57, the /webapi/proxy endpoint on app.lobehub.com accepts a URL in the POST body and fetches it server-side without any authentication. An attacker can use this to make arbitrary outbound requests from LobeHub's infrastructure, leak Vercel deployment details, and inject cookies on the lobehub.com domain through reflected Set-Cookie headers. This vulnerability is fixed in 2.1.57.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54157?

2 open source packages ship an affected version, including @lobehub/lobehub.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/lobehub` | npm | All versions | 2.1.57 |
| `@lobehub/lobehub` | npm | All versions | 2.1.57 |

## How do I fix CVE-2026-54157?

Upgrade @lobehub/lobehub to 2.1.57 or later.

## Is CVE-2026-54157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54157 exists.

Public exploit code:

- LobeHub LobeChat <= 2.1.56 - Server-Side Request Forgery (nuclei): http/cves/2026/CVE-2026-54157.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54157 and fix it if it is affected.

What it is: CVE-2026-54157 is a critical server-side request forgery vulnerability in lobehub, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54157 exists.

Affected packages and fixed versions:
- @lobehub/lobehub (npm): affected all versions; fixed in 2.1.57
- @lobehub/lobehub (npm): affected all versions; fixed in 2.1.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54157/ (Markdown: https://insights.sbomify.com/CVE-2026-54157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54157
- OSV: https://osv.dev/vulnerability/CVE-2026-54157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54157/
Summaries are generated and may contain mistakes; the official description above is the record.
