# CVE-2026-54159: ps_facetedsearch: PHP Object Injection in faceted search cache allows unauthenticated RCE

> Unauthenticated attackers can achieve remote code execution by injecting malicious serialized PHP objects into the faceted search cache.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-m5f5-28qr-9g9r

## What is CVE-2026-54159?

CVE-2026-54159 is a critical unsafe deserialization vulnerability in PrestaShop ps_facetedsearch, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PrestaShop ps_facetedsearch is a module that adds layered navigation filters. From 3.0.0 until 4.0.4, the ps_facetedsearch module rebuilds selected search filters from the request URL, and the value of a slider filter, price or weight, is taken from the URL without sufficient validation and stored in an internal filter-block cache where it is serialized and later read back with a raw native unserialize() in src/Filters/Block.php. By crafting that value, an unauthenticated attacker can smuggle a malicious serialized PHP object into the cache, and when it is deserialized, a gadget chain writes an arbitrary PHP file inside the modules/ps_facetedsearch/ directory, which is then used as a webshell to run commands on the server. This issue is fixed in version 4.0.4.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-54159?

2 open source packages ship an affected version, including prestashop/ps_facetedsearch.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/ps_facetedsearch` | Packagist | From 3.0.0 | 4.0.4 |
| `prestashop/ps_facetedsearch` | Packagist | From 3.0.0 | 4.0.4 |

## How do I fix CVE-2026-54159?

Upgrade prestashop/ps_facetedsearch to 4.0.4 or later.

## Is CVE-2026-54159 being exploited?

There is no known exploitation of CVE-2026-54159 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54159 and fix it if it is affected.

What it is: CVE-2026-54159 is a critical unsafe deserialization vulnerability in PrestaShop ps_facetedsearch, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54159 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/ps_facetedsearch (Packagist): affected from 3.0.0; fixed in 4.0.4
- prestashop/ps_facetedsearch (Packagist): affected from 3.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54159/ (Markdown: https://insights.sbomify.com/CVE-2026-54159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54159
- OSV: https://osv.dev/vulnerability/CVE-2026-54159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54159/
Summaries are generated and may contain mistakes; the official description above is the record.
