{"answers":{"affected":"2 open source packages ship an affected version, including secure_headers.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54163 exists.","fix":"Upgrade secure_headers to 7.3.0 or later.","what":"CVE-2026-54163 is a medium-severity cross-site scripting vulnerability in github secure_headers, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54163 and fix it if it is affected.\n\nWhat it is: CVE-2026-54163 is a medium-severity cross-site scripting vulnerability in github secure_headers, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54163 exists.\n\nAffected packages and fixed versions:\n- secure_headers (RubyGems): affected all versions; fixed in 7.3.0\n- secure_headers (RubyGems): affected all versions; fixed in 7.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54163/ (Markdown: https://insights.sbomify.com/CVE-2026-54163/index.md)","id":"CVE-2026-54163","markdown":"https://insights.sbomify.com/CVE-2026-54163/index.md","name":"CVE-2026-54163","record":{"aliases":["DEBIAN-CVE-2026-54163","GHSA-rqq5-2gf9-4w4q","UBUNTU-CVE-2026-54163"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby security headers library","requires_auth":"none","summary":"Attackers can inject CSP directives to enable XSS or exfiltrate reports via untrusted input in secure_headers library APIs.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-113","name":"Improper Neutralization of CRLF Sequences in HTTP Headers"}],"description":"secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \\r, or \\n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"secure_headers: CSP directive injection via sandbox, plugin_types, and report_to when given untrusted input","id":"CVE-2026-54163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"API Platform Core: Missing IRI type check enables resource type confusion","id":"CVE-2026-54164"},"packages":[{"ecosystem":"RubyGems","fixed":["7.3.0"],"introduced":["0"],"last_affected":[],"package":"secure_headers","purl":null,"source":"GHSA-rqq5-2gf9-4w4q"},{"ecosystem":"RubyGems","fixed":["7.3.0"],"introduced":["0"],"last_affected":[],"package":"secure_headers","purl":"pkg:gem/secure_headers","source":"GHSA-rqq5-2gf9-4w4q"}],"prev":{"headline":"Ember: Unneutralised terminal escape/control sequences from Caddy logs injected into the operator's TUI","id":"CVE-2026-54162"},"products":["secure_headers"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["github"]},"summary":"Attackers can inject CSP directives to enable XSS or exfiltrate reports via untrusted input in secure_headers library APIs.","url":"https://insights.sbomify.com/CVE-2026-54163/"}