# CVE-2026-54163: secure_headers: CSP directive injection via sandbox, plugin_types, and report_to when given untrusted input

> Attackers can inject CSP directives to enable XSS or exfiltrate reports via untrusted input in secure_headers library APIs.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-54163, GHSA-rqq5-2gf9-4w4q, UBUNTU-CVE-2026-54163

## What is CVE-2026-54163?

CVE-2026-54163 is a medium-severity cross-site scripting vulnerability in github secure_headers, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \r, or \n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-54163?

2 open source packages ship an affected version, including secure_headers.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `secure_headers` | RubyGems | All versions | 7.3.0 |
| `secure_headers` | RubyGems | All versions | 7.3.0 |

## How do I fix CVE-2026-54163?

Upgrade secure_headers to 7.3.0 or later.

## Is CVE-2026-54163 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54163 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54163 and fix it if it is affected.

What it is: CVE-2026-54163 is a medium-severity cross-site scripting vulnerability in github secure_headers, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54163 exists.

Affected packages and fixed versions:
- secure_headers (RubyGems): affected all versions; fixed in 7.3.0
- secure_headers (RubyGems): affected all versions; fixed in 7.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54163/ (Markdown: https://insights.sbomify.com/CVE-2026-54163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54163
- OSV: https://osv.dev/vulnerability/CVE-2026-54163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54163/
Summaries are generated and may contain mistakes; the official description above is the record.
