CVE-2026-54164 API Platform Core: Missing IRI type check enables resource type confusion
Attackers can corrupt data invariants by assigning wrong resource types to relations in API Platform Core via type confusion.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54164?
CVE-2026-54164 is a medium-severity vulnerability in api-platform core, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. In versions prior to 4.1.30, 4.2.26 and 4.3.12, the serializer's AbstractItemNormalizer does not validate the resource type returned when resolving relation IRIs, allowing type confusion where a resource of an unintended type can be silently assigned to a relation property. An attacker who can submit write requests (POST/PUT/PATCH) to an API Platform endpoint with writable relations can supply a relation IRI pointing to a resource of a different type than the relation's declared class. Because getResourceFromIri() does not pass an $operation to IriConverter::getResourceFromIri(), the is_a type guard at IriConverter.php:86 is skipped. For untyped relation properties (legacy @var-only style), the wrong-typed object is silently assigned, corrupting invariants and potentially feeding downstream logic that assumes the declared type (CWE-843). For typed properties (modern PHP 8.x), the substitution is blocked by Symfony's PropertyAccessor with an InvalidTypeException. This issue has been fixed in versions 4.1.30, 4.2.26 and 4.3.12.
Weakness: CWE-843
Which versions are affected by CVE-2026-54164?
6 open source packages ship an affected version, including api-platform/core.
| Package | Affected | Fixed in |
|---|---|---|
api-platform/core Packagist | All versions | 4.1.30 |
api-platform/core Packagist | All versions | 4.1.30 |
api-platform/core Packagist | From 4.2.0 | 4.2.26 |
api-platform/core Packagist | From 4.2.0 | 4.2.26 |
api-platform/core Packagist | From 4.3.0 | 4.3.12 |
api-platform/core Packagist | From 4.3.0 | 4.3.12 |
How do I fix CVE-2026-54164?
Upgrade api-platform/core to a fixed version for your release line: 4.1.30, 4.2.26 or 4.3.12.
Is CVE-2026-54164 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54164 exists.
Sources
Also known as GHSA-9rjg-x2p2-h68h.