# CVE-2026-54167: Pipelines-as-Code GitHub App token request can be redirected via untrusted Enterprise Host header

> An attacker can redirect GitHub App token requests to a malicious host via the Enterprise Host header, potentially exposing JWTs for token minting.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-f5f4-3hh4-f54m, GO-2026-6266

## What is CVE-2026-54167?

CVE-2026-54167 is a high-severity server-side request forgery vulnerability in tektoncd pipelines-as-code, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pipelines-as-Code is a CI/CD system that lets users define Tekton pipelines in source code repositories. Prior to 0.37.8, 0.39.6, 0.42.1, and 0.48.0, the GitHub App provider accepts X-GitHub-Enterprise-Host as the API host while processing webhook events containing an installation.id, before webhook signature validation or confirmation that the host matches the repository URL in the signed payload. An unauthenticated attacker who can reach the webhook endpoint can select an attacker-controlled host and cause the controller to send a locally signed GitHub App JWT to that service. The exposed JWT may be used to attempt to mint installation access tokens during its validity window, subject to the GitHub App installation and permissions. The incoming webhook installation-lookup path is also affected, but exploitation of that path requires the valid incoming webhook secret for the target Repository CR. This issue is fixed in versions 0.37.8, 0.39.6, 0.42.1, and 0.48.0.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-54167?

9 open source packages ship an affected version, including github.com/openshift-pipelines/pipelines-as-code.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | All versions | 0.37.8, 0.39.6, 0.42.1, 0.48.0 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | All versions | 0.37.8 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | All versions | 0.37.8 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.38.0 | 0.39.6 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.38.0 | 0.39.6 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.40.0 | 0.42.1 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.40.0 | 0.42.1 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.43.0 | 0.48.0 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.43.0 | 0.48.0 |

## How do I fix CVE-2026-54167?

Upgrade github.com/openshift-pipelines/pipelines-as-code to a fixed version for your release line: 0.37.8, 0.39.6, 0.42.1 or 0.48.0.

## Is CVE-2026-54167 being exploited?

There is no known exploitation of CVE-2026-54167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54167 and fix it if it is affected.

What it is: CVE-2026-54167 is a high-severity server-side request forgery vulnerability in tektoncd pipelines-as-code, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54167 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openshift-pipelines/pipelines-as-code (Go): affected all versions; fixed in 0.37.8, 0.39.6, 0.42.1, 0.48.0
- github.com/openshift-pipelines/pipelines-as-code (Go): affected all versions; fixed in 0.37.8
- github.com/openshift-pipelines/pipelines-as-code (Go): affected all versions; fixed in 0.37.8
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.38.0; fixed in 0.39.6
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.38.0; fixed in 0.39.6
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.40.0; fixed in 0.42.1
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.40.0; fixed in 0.42.1
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.43.0; fixed in 0.48.0
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.43.0; fixed in 0.48.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54167/ (Markdown: https://insights.sbomify.com/CVE-2026-54167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54167
- OSV: https://osv.dev/vulnerability/CVE-2026-54167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54167/
Summaries are generated and may contain mistakes; the official description above is the record.
