# CVE-2026-54168: Tekton Pipelines-as-Code: Unscoped GitHub App installation token allows unauthorized access to private repositories via remote task resolution

> Attackers with push access to one repository can read private Tekton definitions from other repositories in the same GitHub App installation due to unscoped tokens.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-6f2p-296r-cc28, GO-2026-6263

## What is CVE-2026-54168?

CVE-2026-54168 is a medium-severity missing authorization vulnerability in tektoncd pipelines-as-code, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pipelines-as-Code is a CI/CD system that lets users define Tekton pipelines in source code repositories. Prior to 0.37.8, 0.39.6, 0.42.1, and 0.48.0, a GitHub App installation token created during webhook processing is not scoped to the repository that triggered the event when the App is installed across multiple repositories. A user with push access to one repository can submit a PipelineRun containing a pipelinesascode.tekton.dev/task remote task annotation that targets a private repository in the same installation. When ScopeTokenToListOfRepos returns no explicit scope, the missing triggering repository ID leaves the token able to access the entire installation. Pipelines-as-Code resolves and inlines the remote private task with that token, disclosing the repository's Tekton definitions. The demonstrated impact is read-only and does not provide write access. This issue is fixed in versions 0.37.8, 0.39.6, 0.42.1, and 0.48.0.

Weakness: CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-54168?

9 open source packages ship an affected version, including github.com/openshift-pipelines/pipelines-as-code.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | All versions | 0.37.8, 0.39.6, 0.42.1, 0.48.0 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | All versions | 0.37.8 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | All versions | 0.37.8 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.38.0 | 0.39.6 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.38.0 | 0.39.6 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.40.0 | 0.42.1 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.40.0 | 0.42.1 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.43.0 | 0.48.0 |
| `github.com/openshift-pipelines/pipelines-as-code` | Go | From 0.43.0 | 0.48.0 |

## How do I fix CVE-2026-54168?

Upgrade github.com/openshift-pipelines/pipelines-as-code to a fixed version for your release line: 0.37.8, 0.39.6, 0.42.1 or 0.48.0.

## Is CVE-2026-54168 being exploited?

There is no known exploitation of CVE-2026-54168 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54168 and fix it if it is affected.

What it is: CVE-2026-54168 is a medium-severity missing authorization vulnerability in tektoncd pipelines-as-code, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54168 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openshift-pipelines/pipelines-as-code (Go): affected all versions; fixed in 0.37.8, 0.39.6, 0.42.1, 0.48.0
- github.com/openshift-pipelines/pipelines-as-code (Go): affected all versions; fixed in 0.37.8
- github.com/openshift-pipelines/pipelines-as-code (Go): affected all versions; fixed in 0.37.8
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.38.0; fixed in 0.39.6
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.38.0; fixed in 0.39.6
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.40.0; fixed in 0.42.1
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.40.0; fixed in 0.42.1
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.43.0; fixed in 0.48.0
- github.com/openshift-pipelines/pipelines-as-code (Go): affected from 0.43.0; fixed in 0.48.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54168/ (Markdown: https://insights.sbomify.com/CVE-2026-54168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54168
- OSV: https://osv.dev/vulnerability/CVE-2026-54168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54168/
Summaries are generated and may contain mistakes; the official description above is the record.
