{"answers":{"affected":"2 open source packages ship an affected version, including excon. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-54171 in the wild and no public exploit code.","fix":"Upgrade excon to 1.5.0 or later.","what":"CVE-2026-54171 is a medium-severity vulnerability in excon, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54171 and fix it if it is affected.\n\nWhat it is: CVE-2026-54171 is a medium-severity vulnerability in excon, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-54171 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- excon (RubyGems): affected all versions; fixed in 1.5.0\n- excon (RubyGems): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54171/ (Markdown: https://insights.sbomify.com/CVE-2026-54171/index.md)","id":"CVE-2026-54171","markdown":"https://insights.sbomify.com/CVE-2026-54171/index.md","name":"CVE-2026-54171","record":{"aliases":["AZL-92460","CLEANSTART-2026-JH87007","DEBIAN-CVE-2026-54171","GHSA-48rx-c7pg-q66r","MINI-467w-h5vp-cr2f","MINI-95w8-cgrm-rw46","MINI-f58v-f7v8-r8jg","OESA-2026-3100","UBUNTU-CVE-2026-54171"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTTP client library","requires_auth":"none","summary":"Excon library leaks sensitive headers to redirect targets, allowing attackers to read confidential data if redirects are followed.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"excon","vendor":"excon_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-201","name":"Insertion of Sensitive Information Into Sent Data"}],"description":"Excon is usable, fast, simple HTTP 1.1 for Ruby. Prior to 1.5.0, Excon's RedirectFollower middleware failed to strip additional sensitive headers when following redirects and did not provide a custom list of headers to strip. This could cause inadvertent leakage of sensitive data when the initial request includes header information that is not intended for the new target. This issue is fixed in version 1.5.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Excon: redact additional sensitive/risky headers when following redirects","id":"CVE-2026-54171","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"melange: Incomplete package integrity verification allows data section substitution","id":"CVE-2026-54174"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"excon","purl":null,"source":"GHSA-48rx-c7pg-q66r"},{"ecosystem":"RubyGems","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"excon","purl":"pkg:gem/excon","source":"GHSA-48rx-c7pg-q66r"}],"prev":{"headline":"Tekton Pipelines-as-Code: Unscoped GitHub App installation token allows unauthorized access to private repositories via remote task resolution","id":"CVE-2026-54168"},"products":["excon"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["excon"]},"summary":"Excon library leaks sensitive headers to redirect targets, allowing attackers to read confidential data if redirects are followed.","url":"https://insights.sbomify.com/CVE-2026-54171/"}