# CVE-2026-54171: Excon: redact additional sensitive/risky headers when following redirects

> Excon library leaks sensitive headers to redirect targets, allowing attackers to read confidential data if redirects are followed.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** AZL-92460, CLEANSTART-2026-JH87007, DEBIAN-CVE-2026-54171, GHSA-48rx-c7pg-q66r, MINI-467w-h5vp-cr2f, MINI-95w8-cgrm-rw46, MINI-f58v-f7v8-r8jg, OESA-2026-3100, UBUNTU-CVE-2026-54171

## What is CVE-2026-54171?

CVE-2026-54171 is a medium-severity vulnerability in excon, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Excon is usable, fast, simple HTTP 1.1 for Ruby. Prior to 1.5.0, Excon's RedirectFollower middleware failed to strip additional sensitive headers when following redirects and did not provide a custom list of headers to strip. This could cause inadvertent leakage of sensitive data when the initial request includes header information that is not intended for the new target. This issue is fixed in version 1.5.0.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-54171?

2 open source packages ship an affected version, including excon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `excon` | RubyGems | All versions | 1.5.0 |
| `excon` | RubyGems | All versions | 1.5.0 |

Products: Excon Project Excon.

## How do I fix CVE-2026-54171?

Upgrade excon to 1.5.0 or later.

## Is CVE-2026-54171 being exploited?

There is no known exploitation of CVE-2026-54171 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54171 and fix it if it is affected.

What it is: CVE-2026-54171 is a medium-severity vulnerability in excon, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54171 in the wild and no public exploit code.

Affected packages and fixed versions:
- excon (RubyGems): affected all versions; fixed in 1.5.0
- excon (RubyGems): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54171/ (Markdown: https://insights.sbomify.com/CVE-2026-54171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54171
- OSV: https://osv.dev/vulnerability/CVE-2026-54171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54171/
Summaries are generated and may contain mistakes; the official description above is the record.
