# CVE-2026-54174: melange: Incomplete package integrity verification allows data section substitution

> Attackers can substitute package contents during fetches because data section hashes are not verified, allowing malicious code execution.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** CLEANSTART-2026-DP32029, CLEANSTART-2026-MS06455, GHSA-fpg8-7664-jc5q, GO-2026-5968, MINI-2v5v-3h24-46w9, MINI-mc47-6rpp-9mx5, openSUSE-SU-2026:11829-1

## What is CVE-2026-54174?

CVE-2026-54174 is a high-severity vulnerability in chainguard-dev apko, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

melange allows users to build apk packages using declarative pipelines. Apko prior to version 1.2.9, corresponding to melange prior to version 0.50.4, verified the control section hash (`.PKGINFO` etc.) against the signed `APKINDEX`, but never verified the data section hash (the actual package files that get installed). An attacker who could compromise a mirror, poison a cache, or MITM a package fetch could substitute arbitrary file contents while the control hash check still passed. Apko version 1.2.9 and melange version 0.50.4 contain a fix.

Weakness: CWE-354 (Improper Validation of Integrity Check Value), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-54174?

6 open source packages ship an affected version, including chainguard.dev/apko and chainguard.dev/melange.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/apko` | Go | All versions | 1.2.9 |
| `chainguard.dev/apko` | Go | All versions | 1.2.9 |
| `chainguard.dev/apko` | Go | All versions | 1.2.9 |
| `chainguard.dev/melange` | Go | All versions | 0.50.4 |
| `chainguard.dev/melange` | Go | All versions | 0.50.4 |
| `chainguard.dev/melange` | Go | All versions | 0.50.4 |
| `apko` | openSUSE:Tumbleweed | All versions | 1.4.4-1.1 |

## How do I fix CVE-2026-54174?

Upgrade chainguard.dev/apko to 1.2.9 or later.

## Is CVE-2026-54174 being exploited?

There is no known exploitation of CVE-2026-54174 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54174 and fix it if it is affected.

What it is: CVE-2026-54174 is a high-severity vulnerability in chainguard-dev apko, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54174 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/apko (Go): affected all versions; fixed in 1.2.9
- chainguard.dev/apko (Go): affected all versions; fixed in 1.2.9
- chainguard.dev/apko (Go): affected all versions; fixed in 1.2.9
- chainguard.dev/melange (Go): affected all versions; fixed in 0.50.4
- chainguard.dev/melange (Go): affected all versions; fixed in 0.50.4
- chainguard.dev/melange (Go): affected all versions; fixed in 0.50.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54174/ (Markdown: https://insights.sbomify.com/CVE-2026-54174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54174
- OSV: https://osv.dev/vulnerability/CVE-2026-54174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54174/
Summaries are generated and may contain mistakes; the official description above is the record.
