CVE-2026-54175 backpack/crud: Unverified password change in MyAccountController via mass assignment
Authenticated attackers can bypass password verification via mass assignment to change passwords or emails, leading to persistent account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54175?
CVE-2026-54175 is a high-severity vulnerability in Laravel-Backpack CRUD, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Prior to 6.8.11 and 7.0.34, MyAccountController::postAccountInfoForm in src/app/Http/Controllers/MyAccountController.php at POST /admin/edit-account-info passes request data from $request->except(['_token']) to the user model instead of restricting updates to fields accepted by AccountInfoRequest::validationData(). An attacker with an authenticated Backpack session can therefore mass-assign password, the authentication column, or other deployment-specific fillable attributes. With the default Laravel 11 user model, a submitted plaintext password is automatically hashed and persisted, converting temporary session access into persistent account takeover without the old_password check enforced by the separate password-change route. Changing the authentication email can also enable later password-reset takeover, while additional fillable security attributes can permit deployment-specific privilege escalation or security-control changes. This issue is fixed in versions 6.8.11 and 7.0.34.
Weakness: CWE-620
Which versions are affected by CVE-2026-54175?
4 open source packages ship an affected version, including backpack/crud.
| Package | Affected | Fixed in |
|---|---|---|
backpack/crud Packagist | All versions | 6.8.11 |
backpack/crud Packagist | All versions | 6.8.11 |
backpack/crud Packagist | From 7.0.0-alpha.1 | 7.0.34 |
backpack/crud Packagist | From 7.0.0-alpha.1 | 7.0.34 |
How do I fix CVE-2026-54175?
Upgrade backpack/crud to a fixed version for your release line: 6.8.11 or 7.0.34.
Is CVE-2026-54175 being exploited?
There is no known exploitation of CVE-2026-54175 in the wild and no public exploit code.
Sources
Also known as GHSA-xpv2-hrfc-hw62.