CVE-2026-54178 Laravel Backpack CRUD: Arbitrary file deletion via attacker-controlled clear_<attr>[] in HasUploadFields::uploadMultipleFilesToDisk

High 8.1 Published Updated

Authenticated users can delete arbitrary files on the server by manipulating upload field parameters, affecting Laravel Backpack CRUD users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-54178?

CVE-2026-54178 is a high-severity path traversal vulnerability in Laravel-Backpack CRUD, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Prior to 6.8.12 and 7.0.35, HasUploadFields::uploadMultipleFilesToDisk in src/app/Models/Traits/HasUploadFields.php trusts disk-relative paths from clear_<attribute>[] and passes them to Storage::disk()->delete without confirming that the paths are persisted on the current model record. An authenticated user with Update access to a CRUD using this mutator through src/app/Models/Traits/CrudTrait.php can delete another record's attachment, a shared asset, or another operational file on the configured disk by submitting its path. The newer MultipleFiles uploader is not affected because it intersects requested deletions with the record's persisted file list. This flaw does not permit reading the deleted files. The 5.x line remains affected through its final releases. This issue is fixed in versions 6.8.12 and 7.0.35.

Weakness: CWE-639, CWE-285, CWE-22

Which versions are affected by CVE-2026-54178?

6 open source packages ship an affected version, including backpack/crud.

PackageAffectedFixed in
backpack/crud PackagistFrom 5.0.0None
backpack/crud PackagistFrom 5.0.0None
backpack/crud PackagistFrom 6.0.06.8.12
backpack/crud PackagistFrom 6.0.06.8.12
backpack/crud PackagistFrom 7.0.07.0.35
backpack/crud PackagistFrom 7.0.07.0.35

How do I fix CVE-2026-54178?

Upgrade backpack/crud to a fixed version for your release line: 6.8.12 or 7.0.35.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-54178 being exploited?

There is no known exploitation of CVE-2026-54178 in the wild and no public exploit code.

Sources

Also known as GHSA-8xjm-wqrp-2f25.

Is CVE-2026-54178 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free